# CVE-2019-10366: Skytap Cloud CI Plugin stored credentials in plain text

> Attackers with Extended Read permission or master file system access can view unencrypted credentials stored in Jenkins Skytap Cloud CI Plugin configuration files.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 Jul 2019
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-vp26-4hj6-jrvx

## What is CVE-2019-10366?

CVE-2019-10366 is a medium-severity vulnerability in Jenkins Skytap Cloud CI Plugin, published on 31 Jul 2019. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Jenkins Skytap Cloud CI Plugin 2.06 and earlier stored credentials unencrypted in job config.xml files on the Jenkins master where they could be viewed by users with Extended Read permission, or access to the master file system.

Weakness: CWE-522 (Insufficiently Protected Credentials)

## Which versions are affected by CVE-2019-10366?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:skytap. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:skytap` | Maven | All versions | 2.07 |
| `org.jenkins-ci.plugins:skytap` | Maven | All versions | 2.07 |

Products: Jenkins Skytap Cloud Ci.

## How do I fix CVE-2019-10366?

Upgrade org.jenkins-ci.plugins:skytap to 2.07 or later.

## Is CVE-2019-10366 being exploited?

There is no known exploitation of CVE-2019-10366 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Skytap Cloud CI Plugin

- [CVE-2020-2157](https://insights.sbomify.com/CVE-2020-2157/): Credentials transmitted in plain text by Skytap Cloud CI Plugin (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-10366 and fix it if it is affected.

What it is: CVE-2019-10366 is a medium-severity vulnerability in Jenkins Skytap Cloud CI Plugin, published on 31 Jul 2019. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-10366 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:skytap (Maven): affected all versions; fixed in 2.07
- org.jenkins-ci.plugins:skytap (Maven): affected all versions; fixed in 2.07

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-10366/ (Markdown: https://insights.sbomify.com/CVE-2019-10366/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-10366
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-10366
- OSV: https://osv.dev/vulnerability/CVE-2019-10366

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-10366/
Summaries are generated and may contain mistakes; the official description above is the record.
