# CVE-2019-10370: Insertion of Sensitive Information into Log File in Jenkins Mask Passwords Plugin

> Attackers can view globally configured passwords in plain text via the configuration form, exposing sensitive credentials.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 7 Aug 2019
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-gp67-c7j2-2qg2

## What is CVE-2019-10370?

CVE-2019-10370 is a medium-severity vulnerability in Jenkins Mask Passwords Plugin, published on 7 Aug 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Jenkins Mask Passwords Plugin 2.12.0 and earlier transmits globally configured passwords in plain text as part of the configuration form, potentially resulting in their exposure.

Weakness: CWE-532 (Insertion of Sensitive Information into Log File)

## Which versions are affected by CVE-2019-10370?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:mask-passwords. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:mask-passwords` | Maven | All versions | 2.13.0 |
| `org.jenkins-ci.plugins:mask-passwords` | Maven | All versions | 2.13.0 |

Products: Jenkins Mask Passwords.

## How do I fix CVE-2019-10370?

Upgrade org.jenkins-ci.plugins:mask-passwords to 2.13.0 or later.

## Is CVE-2019-10370 being exploited?

There is no known exploitation of CVE-2019-10370 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Mask Passwords Plugin

- [CVE-2022-29043](https://insights.sbomify.com/CVE-2022-29043/): Stored Cross-site Scripting in Jenkins Mask Passwords Plugin (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-10370 and fix it if it is affected.

What it is: CVE-2019-10370 is a medium-severity vulnerability in Jenkins Mask Passwords Plugin, published on 7 Aug 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2019-10370 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:mask-passwords (Maven): affected all versions; fixed in 2.13.0
- org.jenkins-ci.plugins:mask-passwords (Maven): affected all versions; fixed in 2.13.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-10370/ (Markdown: https://insights.sbomify.com/CVE-2019-10370/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-10370
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-10370
- OSV: https://osv.dev/vulnerability/CVE-2019-10370

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-10370/
Summaries are generated and may contain mistakes; the official description above is the record.
