# CVE-2019-10383: Improper Neutralization of Input During Web Page Generation in Jenkins

> Administrators can inject malicious scripts into Jenkins update center pages via the update site URL configuration, potentially compromising user sessions.

- **Severity:** Medium 4.8 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 28 Aug 2019
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-9m48-54pj-h248

## What is CVE-2019-10383?

CVE-2019-10383 is a medium-severity cross-site scripting vulnerability in Jenkins Jenkins, published on 28 Aug 2019. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

A stored cross-site scripting vulnerability in Jenkins 2.191 and earlier, LTS 2.176.2 and earlier allowed attackers with Overall/Administer permission to configure the update site URL to inject arbitrary HTML and JavaScript in update center web pages.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2019-10383?

4 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.main:jenkins-core` | Maven | All versions | 2.176.3 |
| `org.jenkins-ci.main:jenkins-core` | Maven | All versions | 2.176.3 |
| `org.jenkins-ci.main:jenkins-core` | Maven | From 2.177 | 2.192 |
| `org.jenkins-ci.main:jenkins-core` | Maven | From 2.177 | 2.192 |

Products: Jenkins Jenkins, Oracle Communications Cloud Native Core Automated Test Suite, Redhat Openshift Container Platform.

## How do I fix CVE-2019-10383?

Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 2.176.3 or 2.192.

## Is CVE-2019-10383 being exploited?

There is no known exploitation of CVE-2019-10383 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Jenkins

- [CVE-2024-23897](https://insights.sbomify.com/CVE-2024-23897/): Jenkins Command Line Interface (CLI) Path Traversal (critical 9.8, exploited in the wild)
- [CVE-2018-1000861](https://insights.sbomify.com/CVE-2018-1000861/): Jenkins Stapler Web Framework Deserialization of Untrusted Data (critical 9.8, exploited in the wild)
- [CVE-2017-1000353](https://insights.sbomify.com/CVE-2017-1000353/): Jenkins Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2015-5317](https://insights.sbomify.com/CVE-2015-5317/): Jenkins User Interface (UI) Information Disclosure (high 7.5, exploited in the wild)
- [CVE-2021-21690](https://insights.sbomify.com/CVE-2021-21690/): Multiple vulnerabilities allow bypassing path filtering of agent-to-controller access control in Jenkins (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-10383 and fix it if it is affected.

What it is: CVE-2019-10383 is a medium-severity cross-site scripting vulnerability in Jenkins Jenkins, published on 28 Aug 2019. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2019-10383 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.main:jenkins-core (Maven): affected all versions; fixed in 2.176.3
- org.jenkins-ci.main:jenkins-core (Maven): affected all versions; fixed in 2.176.3
- org.jenkins-ci.main:jenkins-core (Maven): affected from 2.177; fixed in 2.192
- org.jenkins-ci.main:jenkins-core (Maven): affected from 2.177; fixed in 2.192

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-10383/ (Markdown: https://insights.sbomify.com/CVE-2019-10383/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-10383
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-10383
- OSV: https://osv.dev/vulnerability/CVE-2019-10383

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-10383/
Summaries are generated and may contain mistakes; the official description above is the record.
