# CVE-2019-10390: Jenkins Splunk Plugin Sandbox Bypass

> Attackers with read permissions can execute arbitrary code on the Jenkins master via a Groovy script injection in the Splunk plugin.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Aug 2019
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-cjr8-5rw4-wh65

## What is CVE-2019-10390?

CVE-2019-10390 is a high-severity code injection vulnerability in Jenkins Splunk Plugin, published on 28 Aug 2019. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A sandbox bypass vulnerability in Jenkins Splunk Plugin 1.7.4 and earlier allowed attackers with Overall/Read permission to provide a Groovy script to an HTTP endpoint that can result in arbitrary code execution on the Jenkins master JVM.

## Which versions are affected by CVE-2019-10390?

2 open source packages ship an affected version, including com.splunk.splunkins:splunk-devops. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.splunk.splunkins:splunk-devops` | Maven | All versions | 1.8.0 |
| `com.splunk.splunkins:splunk-devops` | Maven | All versions | 1.8.0 |

Products: Jenkins Splunk.

## How do I fix CVE-2019-10390?

Upgrade com.splunk.splunkins:splunk-devops to 1.8.0 or later.

## Is CVE-2019-10390 being exploited?

There is no known exploitation of CVE-2019-10390 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-10390 and fix it if it is affected.

What it is: CVE-2019-10390 is a high-severity code injection vulnerability in Jenkins Splunk Plugin, published on 28 Aug 2019. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-10390 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.splunk.splunkins:splunk-devops (Maven): affected all versions; fixed in 1.8.0
- com.splunk.splunkins:splunk-devops (Maven): affected all versions; fixed in 1.8.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-10390/ (Markdown: https://insights.sbomify.com/CVE-2019-10390/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-10390
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-10390
- OSV: https://osv.dev/vulnerability/CVE-2019-10390

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-10390/
Summaries are generated and may contain mistakes; the official description above is the record.
