{"answers":{"affected":"2 open source packages ship an affected version, including org.jenkins-ci.plugins:build-environment. It affects 1 product.","exploited":"There is no known exploitation of CVE-2019-10395 in the wild and no public exploit code.","fix":"Upgrade org.jenkins-ci.plugins:build-environment to 1.7 or later.","what":"CVE-2019-10395 is a medium-severity cross-site scripting vulnerability in Jenkins Build Environment Plugin, published on 12 Sep 2019. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2019-10395 and fix it if it is affected.\n\nWhat it is: CVE-2019-10395 is a medium-severity cross-site scripting vulnerability in Jenkins Build Environment Plugin, published on 12 Sep 2019. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2019-10395 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jenkins-ci.plugins:build-environment (Maven): affected all versions; fixed in 1.7\n- org.jenkins-ci.plugins:build-environment (Maven): affected all versions; fixed in 1.7\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-10395/ (Markdown: https://insights.sbomify.com/CVE-2019-10395/index.md)","id":"CVE-2019-10395","markdown":"https://insights.sbomify.com/CVE-2019-10395/index.md","name":"CVE-2019-10395","record":{"aliases":["GHSA-88qj-3q6h-8m5q"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins Build Environment Plugin","requires_auth":"low_privilege","summary":"Cross-site scripting in Jenkins Build Environment Plugin allows attackers to execute scripts via unescaped variables in job views.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jenkins","cpe":[{"product":"build_environment","vendor":"jenkins"}],"cvss":{"score":5.4,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Jenkins Build Environment Plugin 1.6 and earlier did not escape variables shown on its views, resulting in a cross-site scripting vulnerability in Jenkins 2.145, 2.138.1, or older, exploitable by users able to change various job/build properties.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Jenkins Build Environment Plugin vulnerable to Cross-site Scripting","id":"CVE-2019-10395","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xss","year":"2019"},"n_packages":2,"n_references":2,"next":{"headline":"Jenkins Dashboard View Plugin vulnerable to Cross-site Scripting","id":"CVE-2019-10396"},"packages":[{"ecosystem":"Maven","fixed":["1.7"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:build-environment","purl":null,"source":"GHSA-88qj-3q6h-8m5q"},{"ecosystem":"Maven","fixed":["1.7"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:build-environment","purl":"pkg:maven/org.jenkins-ci.plugins/build-environment","source":"GHSA-88qj-3q6h-8m5q"}],"prev":{"headline":"Sandbox bypass vulnerability in Jenkins Script Security Plugin","id":"CVE-2019-10394"},"products":["Jenkins Build Environment Plugin"],"published":"2019-09-12","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["Jenkins project"]},"summary":"Cross-site scripting in Jenkins Build Environment Plugin allows attackers to execute scripts via unescaped variables in job views.","url":"https://insights.sbomify.com/CVE-2019-10395/"}