# CVE-2019-10396: Jenkins Dashboard View Plugin vulnerable to Cross-site Scripting

> Attackers can inject malicious scripts via build descriptions in the Jenkins Dashboard View Plugin, potentially compromising user sessions.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 12 Sep 2019
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-fv4q-4h24-23qr

## What is CVE-2019-10396?

CVE-2019-10396 is a medium-severity cross-site scripting vulnerability in Jenkins Dashboard View Plugin, published on 12 Sep 2019. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Jenkins Dashboard View Plugin 2.11 and earlier did not escape build descriptions, resulting in a cross-site scripting vulnerability exploitable by users able to change build descriptions.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2019-10396?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:dashboard-view. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:dashboard-view` | Maven | All versions | 2.12 |
| `org.jenkins-ci.plugins:dashboard-view` | Maven | All versions | 2.12 |

Products: Jenkins Dashboard View.

## How do I fix CVE-2019-10396?

Upgrade org.jenkins-ci.plugins:dashboard-view to 2.12 or later.

## Is CVE-2019-10396 being exploited?

There is no known exploitation of CVE-2019-10396 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Dashboard View Plugin

- [CVE-2022-27197](https://insights.sbomify.com/CVE-2022-27197/): Stored Cross-site Scripting vulnerability in Jenkins Dashboard View Plugin (medium 5.4)
- [CVE-2021-21649](https://insights.sbomify.com/CVE-2021-21649/): Cross-site Scripting in Jenkins Dashboard View Plugin (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-10396 and fix it if it is affected.

What it is: CVE-2019-10396 is a medium-severity cross-site scripting vulnerability in Jenkins Dashboard View Plugin, published on 12 Sep 2019. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2019-10396 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:dashboard-view (Maven): affected all versions; fixed in 2.12
- org.jenkins-ci.plugins:dashboard-view (Maven): affected all versions; fixed in 2.12

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-10396/ (Markdown: https://insights.sbomify.com/CVE-2019-10396/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-10396
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-10396
- OSV: https://osv.dev/vulnerability/CVE-2019-10396

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-10396/
Summaries are generated and may contain mistakes; the official description above is the record.
