# CVE-2019-10405: Exposure of Sensitive Information to an Unauthorized Actor in Jenkins

> Jenkins exposed session cookies via the /whoAmI/ endpoint, allowing attackers to steal HttpOnly cookies and hijack user sessions.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Sep 2019
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-47wc-p5cp-w7pw

## What is CVE-2019-10405?

CVE-2019-10405 is a medium-severity vulnerability in Jenkins Jenkins, published on 25 Sep 2019. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Jenkins 2.196 and earlier, LTS 2.176.3 and earlier printed the value of the "Cookie" HTTP request header on the /whoAmI/ URL, allowing attackers exploiting another XSS vulnerability to obtain the HTTP session cookie despite it being marked HttpOnly.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2019-10405?

4 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.main:jenkins-core` | Maven | All versions | 2.176.4 |
| `org.jenkins-ci.main:jenkins-core` | Maven | All versions | 2.176.4 |
| `org.jenkins-ci.main:jenkins-core` | Maven | From 2.177 | 2.197 |
| `org.jenkins-ci.main:jenkins-core` | Maven | From 2.177 | 2.197 |

Products: Jenkins Jenkins.

## How do I fix CVE-2019-10405?

Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 2.176.4 or 2.197.

## Is CVE-2019-10405 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2019-10405 exists.

Public exploit code:

- Jenkins <=2.196 - Cookie Exposure (nuclei): http/cves/2019/CVE-2019-10405.yaml

## Other vulnerabilities in Jenkins Jenkins

- [CVE-2024-23897](https://insights.sbomify.com/CVE-2024-23897/): Jenkins Command Line Interface (CLI) Path Traversal (critical 9.8, exploited in the wild)
- [CVE-2018-1000861](https://insights.sbomify.com/CVE-2018-1000861/): Jenkins Stapler Web Framework Deserialization of Untrusted Data (critical 9.8, exploited in the wild)
- [CVE-2017-1000353](https://insights.sbomify.com/CVE-2017-1000353/): Jenkins Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2015-5317](https://insights.sbomify.com/CVE-2015-5317/): Jenkins User Interface (UI) Information Disclosure (high 7.5, exploited in the wild)
- [CVE-2021-21690](https://insights.sbomify.com/CVE-2021-21690/): Multiple vulnerabilities allow bypassing path filtering of agent-to-controller access control in Jenkins (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-10405 and fix it if it is affected.

What it is: CVE-2019-10405 is a medium-severity vulnerability in Jenkins Jenkins, published on 25 Sep 2019. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2019-10405 exists.

Affected packages and fixed versions:
- org.jenkins-ci.main:jenkins-core (Maven): affected all versions; fixed in 2.176.4
- org.jenkins-ci.main:jenkins-core (Maven): affected all versions; fixed in 2.176.4
- org.jenkins-ci.main:jenkins-core (Maven): affected from 2.177; fixed in 2.197
- org.jenkins-ci.main:jenkins-core (Maven): affected from 2.177; fixed in 2.197

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-10405/ (Markdown: https://insights.sbomify.com/CVE-2019-10405/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-10405
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-10405
- OSV: https://osv.dev/vulnerability/CVE-2019-10405

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-10405/
Summaries are generated and may contain mistakes; the official description above is the record.
