{"answers":{"affected":"2 open source packages ship an affected version, including org.jenkins-ci.plugins:log-parser. It affects 1 product.","exploited":"There is no known exploitation of CVE-2019-10410 in the wild and no public exploit code.","fix":"Upgrade org.jenkins-ci.plugins:log-parser to 2.1 or later.","what":"CVE-2019-10410 is a medium-severity cross-site scripting vulnerability in Jenkins Log Parser Plugin, published on 25 Sep 2019. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2019-10410 and fix it if it is affected.\n\nWhat it is: CVE-2019-10410 is a medium-severity cross-site scripting vulnerability in Jenkins Log Parser Plugin, published on 25 Sep 2019. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2019-10410 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jenkins-ci.plugins:log-parser (Maven): affected all versions; fixed in 2.1\n- org.jenkins-ci.plugins:log-parser (Maven): affected all versions; fixed in 2.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-10410/ (Markdown: https://insights.sbomify.com/CVE-2019-10410/index.md)","id":"CVE-2019-10410","markdown":"https://insights.sbomify.com/CVE-2019-10410/index.md","name":"CVE-2019-10410","record":{"aliases":["GHSA-xqqw-cqjp-52xm"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins Log Parser Plugin","requires_auth":"low_privilege","summary":"Attackers with log parsing rule definition privileges can execute arbitrary scripts in victim browsers via unescaped error messages.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jenkins","cpe":[{"product":"log_parser","vendor":"jenkins"}],"cvss":{"score":5.4,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Jenkins Log Parser Plugin 2.0 and earlier did not escape an error message, resulting in a cross-site scripting vulnerability exploitable by users able to define log parsing rules.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Jenkins Log Parser Plugin vulnerable to Cross-site Scripting","id":"CVE-2019-10410","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xss","year":"2019"},"n_packages":2,"n_references":2,"next":{"headline":"Jenkins Inedo BuildMaster Plugin showed plain text password in configuration form","id":"CVE-2019-10411"},"packages":[{"ecosystem":"Maven","fixed":["2.1"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:log-parser","purl":null,"source":"GHSA-xqqw-cqjp-52xm"},{"ecosystem":"Maven","fixed":["2.1"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:log-parser","purl":"pkg:maven/org.jenkins-ci.plugins/log-parser","source":"GHSA-xqqw-cqjp-52xm"}],"prev":{"headline":"Missing permission check in Jenkins Project Inheritance Plugin","id":"CVE-2019-10409"},"products":["Jenkins Log Parser Plugin"],"published":"2019-09-25","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["Jenkins project"]},"summary":"Attackers with log parsing rule definition privileges can execute arbitrary scripts in victim browsers via unescaped error messages.","url":"https://insights.sbomify.com/CVE-2019-10410/"}