# CVE-2019-10413: Jenkins Data Theorem Mobile Security: CI/CD Plugin has Insufficiently Protected Credentials

> Attackers with Extended Read permission or master file system access can view unencrypted credentials stored in Jenkins job configuration files.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Sep 2019
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-jjmv-6fv4-85vf

## What is CVE-2019-10413?

CVE-2019-10413 is a medium-severity vulnerability in Jenkins Data Theorem: CI/CD Plugin, published on 25 Sep 2019. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Jenkins Data Theorem: CI/CD Plugin 1.3 and earlier stored credentials unencrypted in job config.xml files on the Jenkins master where they could be viewed by users with Extended Read permission, or access to the master file system.

Weakness: CWE-522 (Insufficiently Protected Credentials)

## Which versions are affected by CVE-2019-10413?

2 open source packages ship an affected version, including com.datatheorem.mobileappsecurity.jenkins.plugin:datatheorem-mobile-app-security. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.datatheorem.mobileappsecurity.jenkins.plugin:datatheorem-mobile-app-security` | Maven | All versions | 1.4.0 |
| `com.datatheorem.mobileappsecurity.jenkins.plugin:datatheorem-mobile-app-security` | Maven | All versions | 1.4.0 |

Products: Jenkins Data Theorem Mobile App Security.

## How do I fix CVE-2019-10413?

Upgrade com.datatheorem.mobileappsecurity.jenkins.plugin:datatheorem-mobile-app-security to 1.4.0 or later.

## Is CVE-2019-10413 being exploited?

There is no known exploitation of CVE-2019-10413 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-10413 and fix it if it is affected.

What it is: CVE-2019-10413 is a medium-severity vulnerability in Jenkins Data Theorem: CI/CD Plugin, published on 25 Sep 2019. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-10413 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.datatheorem.mobileappsecurity.jenkins.plugin:datatheorem-mobile-app-security (Maven): affected all versions; fixed in 1.4.0
- com.datatheorem.mobileappsecurity.jenkins.plugin:datatheorem-mobile-app-security (Maven): affected all versions; fixed in 1.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-10413/ (Markdown: https://insights.sbomify.com/CVE-2019-10413/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-10413
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-10413
- OSV: https://osv.dev/vulnerability/CVE-2019-10413

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-10413/
Summaries are generated and may contain mistakes; the official description above is the record.
