{"answers":{"affected":"2 open source packages ship an affected version, including org.jenkins-ci.plugins:violation-comments-to-gitlab. It affects 1 product.","exploited":"There is no known exploitation of CVE-2019-10415 in the wild and no public exploit code.","fix":"Upgrade org.jenkins-ci.plugins:violation-comments-to-gitlab to 2.29 or later.","what":"CVE-2019-10415 is a medium-severity vulnerability in Jenkins Violation Comments to GitLab Plugin, published on 25 Sep 2019. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2019-10415 and fix it if it is affected.\n\nWhat it is: CVE-2019-10415 is a medium-severity vulnerability in Jenkins Violation Comments to GitLab Plugin, published on 25 Sep 2019. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2019-10415 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jenkins-ci.plugins:violation-comments-to-gitlab (Maven): affected all versions; fixed in 2.29\n- org.jenkins-ci.plugins:violation-comments-to-gitlab (Maven): affected all versions; fixed in 2.29\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-10415/ (Markdown: https://insights.sbomify.com/CVE-2019-10415/index.md)","id":"CVE-2019-10415","markdown":"https://insights.sbomify.com/CVE-2019-10415/index.md","name":"CVE-2019-10415","record":{"aliases":["GHSA-8hwr-589g-xpj2"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins GitLab plugin","requires_auth":"low_privilege","summary":"Attackers with master file system access can read unencrypted GitLab credentials stored by the Jenkins Violation Comments plugin.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jenkins","cpe":[{"product":"violation_comments_to_gitlab","vendor":"jenkins"}],"cvss":{"score":6.5,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-522","name":"Insufficiently Protected Credentials"}],"description":"Jenkins Violation Comments to GitLab Plugin 2.28 and earlier stored credentials unencrypted in its global configuration file on the Jenkins master where they could be viewed by users with access to the master file system.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Jenkins Violation Comments to GitLab Plugin has Insufficiently Protected Credentials","id":"CVE-2019-10415","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"information_disclosure","year":"2019"},"n_packages":2,"n_references":2,"next":{"headline":"Violation Comments to GitLab Plugin has Insufficiently Protected Credentials","id":"CVE-2019-10416"},"packages":[{"ecosystem":"Maven","fixed":["2.29"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:violation-comments-to-gitlab","purl":null,"source":"GHSA-8hwr-589g-xpj2"},{"ecosystem":"Maven","fixed":["2.29"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:violation-comments-to-gitlab","purl":"pkg:maven/org.jenkins-ci.plugins/violation-comments-to-gitlab","source":"GHSA-8hwr-589g-xpj2"}],"prev":{"headline":"Jenkins Git Changelog Plugin has Insufficiently Protected Credentials","id":"CVE-2019-10414"},"products":["Jenkins Violation Comments to GitLab Plugin"],"published":"2019-09-25","related":[{"cvss_score":6.5,"headline":"Violation Comments to GitLab Plugin has Insufficiently Protected Credentials","id":"CVE-2019-10416","kev_date_added":null,"published":"2019-09-25"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["Jenkins project"]},"summary":"Attackers with master file system access can read unencrypted GitLab credentials stored by the Jenkins Violation Comments plugin.","url":"https://insights.sbomify.com/CVE-2019-10415/"}