# CVE-2019-10436: Improper Limitation of a Pathname to a Restricted Directory in Jenkins Google OAuth Credentials Plugin

> Attackers with job configuration privileges can read arbitrary files on the Jenkins master via the Google OAuth Credentials Plugin.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Oct 2019
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-8qh4-fghr-6fxg

## What is CVE-2019-10436?

CVE-2019-10436 is a medium-severity path traversal vulnerability in Jenkins Google OAuth Credentials Plugin, published on 16 Oct 2019. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

An arbitrary file read vulnerability in Jenkins Google OAuth Credentials Plugin 0.9 and earlier allowed attackers able to configure jobs and credentials in Jenkins to obtain the contents of any file on the Jenkins master.

## Which versions are affected by CVE-2019-10436?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:google-oauth-plugin. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:google-oauth-plugin` | Maven | All versions | 0.10 |
| `org.jenkins-ci.plugins:google-oauth-plugin` | Maven | All versions | 0.10 |

Products: Jenkins Google Oauth Credentials.

## How do I fix CVE-2019-10436?

Upgrade org.jenkins-ci.plugins:google-oauth-plugin to 0.10 or later.

## Is CVE-2019-10436 being exploited?

There is no known exploitation of CVE-2019-10436 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-10436 and fix it if it is affected.

What it is: CVE-2019-10436 is a medium-severity path traversal vulnerability in Jenkins Google OAuth Credentials Plugin, published on 16 Oct 2019. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-10436 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:google-oauth-plugin (Maven): affected all versions; fixed in 0.10
- org.jenkins-ci.plugins:google-oauth-plugin (Maven): affected all versions; fixed in 0.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-10436/ (Markdown: https://insights.sbomify.com/CVE-2019-10436/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-10436
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-10436
- OSV: https://osv.dev/vulnerability/CVE-2019-10436

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-10436/
Summaries are generated and may contain mistakes; the official description above is the record.
