{"answers":{"affected":"2 open source packages ship an affected version, including org.jenkins-ci.plugins:crx-content-package-deployer. It affects 1 product.","exploited":"There is no known exploitation of CVE-2019-10437 in the wild and no public exploit code.","fix":"Upgrade org.jenkins-ci.plugins:crx-content-package-deployer to 1.9 or later.","what":"CVE-2019-10437 is a high-severity vulnerability in Jenkins CRX Content Package Deployer Plugin, published on 16 Oct 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2019-10437 and fix it if it is affected.\n\nWhat it is: CVE-2019-10437 is a high-severity vulnerability in Jenkins CRX Content Package Deployer Plugin, published on 16 Oct 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2019-10437 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jenkins-ci.plugins:crx-content-package-deployer (Maven): affected all versions; fixed in 1.9\n- org.jenkins-ci.plugins:crx-content-package-deployer (Maven): affected all versions; fixed in 1.9\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-10437/ (Markdown: https://insights.sbomify.com/CVE-2019-10437/index.md)","id":"CVE-2019-10437","markdown":"https://insights.sbomify.com/CVE-2019-10437/index.md","name":"CVE-2019-10437","record":{"aliases":["GHSA-62fp-j75q-mqhc"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins CRX Plugin","requires_auth":"none","summary":"Attackers can exploit CSRF to connect to malicious URLs using stolen credentials, capturing sensitive data stored in Jenkins.","user_interaction":"required","vuln_class":"csrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jenkins","cpe":[{"product":"crx_content_package_deployer","vendor":"jenkins"}],"cvss":{"score":8.8,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-352","name":"Cross-Site Request Forgery"}],"description":"A cross-site request forgery vulnerability in Jenkins CRX Content Package Deployer Plugin 1.8.1 and earlier allowed attackers to connect to an attacker-specified URL using attacker-specified credentials IDs obtained through another method, capturing credentials stored in Jenkins.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Jenkins CRX Content Package Deployer Plugin subject to Cross-Site Request Forgery","id":"CVE-2019-10437","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"csrf","year":"2019"},"n_packages":2,"n_references":1,"next":{"headline":"Jenkins CRX Content Package Deployer Plugin subject to Missing Authorization","id":"CVE-2019-10438"},"packages":[{"ecosystem":"Maven","fixed":["1.9"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:crx-content-package-deployer","purl":null,"source":"GHSA-62fp-j75q-mqhc"},{"ecosystem":"Maven","fixed":["1.9"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:crx-content-package-deployer","purl":"pkg:maven/org.jenkins-ci.plugins/crx-content-package-deployer","source":"GHSA-62fp-j75q-mqhc"}],"prev":{"headline":"Improper Limitation of a Pathname to a Restricted Directory in Jenkins Google OAuth Credentials Plugin","id":"CVE-2019-10436"},"products":["Jenkins CRX Content Package Deployer Plugin"],"published":"2019-10-16","related":[{"cvss_score":6.5,"headline":"Jenkins CRX Content Package Deployer Plugin subject to Missing Authorization","id":"CVE-2019-10438","kev_date_added":null,"published":"2019-10-16"},{"cvss_score":5.4,"headline":"Cross-site Scripting in Jenkins CRX Content Package Deployer Plugin","id":"CVE-2022-34184","kev_date_added":null,"published":"2022-06-22"},{"cvss_score":4.3,"headline":"Jenkins CRX Content Package Deployer Plugin subject to credentials enumeration via Missing Authorization","id":"CVE-2019-10439","kev_date_added":null,"published":"2019-10-16"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["Jenkins project"]},"summary":"Attackers can exploit CSRF to connect to malicious URLs using stolen credentials, capturing sensitive data stored in Jenkins.","url":"https://insights.sbomify.com/CVE-2019-10437/"}