{"answers":{"affected":"2 open source packages ship an affected version, including org.jenkins-ci.plugins:icescrum. It affects 1 product.","exploited":"There is no known exploitation of CVE-2019-10441 in the wild and no public exploit code.","fix":"Upgrade org.jenkins-ci.plugins:icescrum to 1.1.6 or later.","what":"CVE-2019-10441 is a medium-severity vulnerability in Jenkins iceScrum Plugin, published on 16 Oct 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2019-10441 and fix it if it is affected.\n\nWhat it is: CVE-2019-10441 is a medium-severity vulnerability in Jenkins iceScrum Plugin, published on 16 Oct 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2019-10441 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jenkins-ci.plugins:icescrum (Maven): affected all versions; fixed in 1.1.6\n- org.jenkins-ci.plugins:icescrum (Maven): affected all versions; fixed in 1.1.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-10441/ (Markdown: https://insights.sbomify.com/CVE-2019-10441/index.md)","id":"CVE-2019-10441","markdown":"https://insights.sbomify.com/CVE-2019-10441/index.md","name":"CVE-2019-10441","record":{"aliases":["GHSA-rxvx-9wg5-qpww"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["security_bypass","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins iceScrum Plugin","requires_auth":"none","summary":"Attackers can exploit CSRF to force Jenkins users to connect to malicious URLs using their credentials, potentially exposing sensitive data.","user_interaction":"required","vuln_class":"csrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jenkins","cpe":[{"product":"icescrum","vendor":"jenkins"}],"cvss":{"score":4.3,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-352","name":"Cross-Site Request Forgery"}],"description":"A cross-site request forgery vulnerability in Jenkins iceScrum Plugin 1.1.5 and earlier allowed attackers to connect to an attacker-specified URL using attacker-specified credentials.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Jenkins iceScrum Plugin vulnerable to Cross-site Request Forgery","id":"CVE-2019-10441","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"csrf","year":"2019"},"n_packages":2,"n_references":1,"next":{"headline":"Jenkins iceScrum Plugin vulnerable to Missing Authorization","id":"CVE-2019-10442"},"packages":[{"ecosystem":"Maven","fixed":["1.1.6"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:icescrum","purl":null,"source":"GHSA-rxvx-9wg5-qpww"},{"ecosystem":"Maven","fixed":["1.1.6"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:icescrum","purl":"pkg:maven/org.jenkins-ci.plugins/icescrum","source":"GHSA-rxvx-9wg5-qpww"}],"prev":{"headline":"Jenkins NeoLoad Plugin stores credentials in cleartext","id":"CVE-2019-10440"},"products":["Jenkins iceScrum Plugin"],"published":"2019-10-16","related":[{"cvss_score":8.8,"headline":"Jenkins iceScrum Plugin vulnerable to stored Cross-site Scripting","id":"CVE-2024-28160","kev_date_added":null,"published":"2024-03-06"},{"cvss_score":8.8,"headline":"Jenkins iceScrum Plugin stores credentials in Cleartext","id":"CVE-2019-10443","kev_date_added":null,"published":"2019-10-16"},{"cvss_score":4.3,"headline":"Jenkins iceScrum Plugin vulnerable to Missing Authorization","id":"CVE-2019-10442","kev_date_added":null,"published":"2019-10-16"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["Jenkins project"]},"summary":"Attackers can exploit CSRF to force Jenkins users to connect to malicious URLs using their credentials, potentially exposing sensitive data.","url":"https://insights.sbomify.com/CVE-2019-10441/"}