# CVE-2019-10441: Jenkins iceScrum Plugin vulnerable to Cross-site Request Forgery

> Attackers can exploit CSRF to force Jenkins users to connect to malicious URLs using their credentials, potentially exposing sensitive data.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 16 Oct 2019
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-rxvx-9wg5-qpww

## What is CVE-2019-10441?

CVE-2019-10441 is a medium-severity vulnerability in Jenkins iceScrum Plugin, published on 16 Oct 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

A cross-site request forgery vulnerability in Jenkins iceScrum Plugin 1.1.5 and earlier allowed attackers to connect to an attacker-specified URL using attacker-specified credentials.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2019-10441?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:icescrum. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:icescrum` | Maven | All versions | 1.1.6 |
| `org.jenkins-ci.plugins:icescrum` | Maven | All versions | 1.1.6 |

Products: Jenkins Icescrum.

## How do I fix CVE-2019-10441?

Upgrade org.jenkins-ci.plugins:icescrum to 1.1.6 or later.

## Is CVE-2019-10441 being exploited?

There is no known exploitation of CVE-2019-10441 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins iceScrum Plugin

- [CVE-2024-28160](https://insights.sbomify.com/CVE-2024-28160/): Jenkins iceScrum Plugin vulnerable to stored Cross-site Scripting (high 8.8)
- [CVE-2019-10443](https://insights.sbomify.com/CVE-2019-10443/): Jenkins iceScrum Plugin stores credentials in Cleartext (high 8.8)
- [CVE-2019-10442](https://insights.sbomify.com/CVE-2019-10442/): Jenkins iceScrum Plugin vulnerable to Missing Authorization (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-10441 and fix it if it is affected.

What it is: CVE-2019-10441 is a medium-severity vulnerability in Jenkins iceScrum Plugin, published on 16 Oct 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2019-10441 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:icescrum (Maven): affected all versions; fixed in 1.1.6
- org.jenkins-ci.plugins:icescrum (Maven): affected all versions; fixed in 1.1.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-10441/ (Markdown: https://insights.sbomify.com/CVE-2019-10441/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-10441
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-10441
- OSV: https://osv.dev/vulnerability/CVE-2019-10441

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-10441/
Summaries are generated and may contain mistakes; the official description above is the record.
