# CVE-2019-10445: Missing permission checks in Google Kubernetes Engine Jenkins Plugin

> Attackers with read permissions can access limited credential scope information due to missing permission checks in the Jenkins GKE plugin.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Oct 2019
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-wwr4-79jv-297r

## What is CVE-2019-10445?

CVE-2019-10445 is a medium-severity missing authorization vulnerability in Jenkins Google Kubernetes Engine Plugin, published on 16 Oct 2019. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A missing permission check in Jenkins Google Kubernetes Engine Plugin 0.7.0 and earlier allowed attackers with Overall/Read permission to obtain limited information about the scope of a credential with an attacker-specified credentials ID.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2019-10445?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:google-kubernetes-engine. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:google-kubernetes-engine` | Maven | All versions | 0.7.1 |
| `org.jenkins-ci.plugins:google-kubernetes-engine` | Maven | All versions | 0.7.1 |

Products: Jenkins Google Kubernetes Engine.

## How do I fix CVE-2019-10445?

Upgrade org.jenkins-ci.plugins:google-kubernetes-engine to 0.7.1 or later.

## Is CVE-2019-10445 being exploited?

There is no known exploitation of CVE-2019-10445 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Google Kubernetes Engine Plugin

- [CVE-2020-2121](https://insights.sbomify.com/CVE-2020-2121/): RCE vulnerability in Google Kubernetes Engine Plugin (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-10445 and fix it if it is affected.

What it is: CVE-2019-10445 is a medium-severity missing authorization vulnerability in Jenkins Google Kubernetes Engine Plugin, published on 16 Oct 2019. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-10445 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:google-kubernetes-engine (Maven): affected all versions; fixed in 0.7.1
- org.jenkins-ci.plugins:google-kubernetes-engine (Maven): affected all versions; fixed in 0.7.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-10445/ (Markdown: https://insights.sbomify.com/CVE-2019-10445/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-10445
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-10445
- OSV: https://osv.dev/vulnerability/CVE-2019-10445

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-10445/
Summaries are generated and may contain mistakes; the official description above is the record.
