# CVE-2019-10472: Jenkins Libvirt Slaves Plugin vlnerable to Incorrect Default Permissions

> Attackers with read access can connect to malicious SSH servers to capture Jenkins credentials due to missing permission checks.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Oct 2019
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-m36j-f2hf-qgj2

## What is CVE-2019-10472?

CVE-2019-10472 is a medium-severity missing authorization vulnerability in Jenkins Libvirt Slaves Plugin, published on 23 Oct 2019. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A missing permission check in Jenkins Libvirt Slaves Plugin allows attackers with Overall/Read permission to connect to an attacker-specified SSH server using attacker-specified credentials IDs obtained through another method, capturing credentials stored in Jenkins.

Weakness: CWE-276 (Incorrect Default Permissions)

## Which versions are affected by CVE-2019-10472?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:libvirt-slave. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:libvirt-slave` | Maven | All versions | 1.8.6 |
| `org.jenkins-ci.plugins:libvirt-slave` | Maven | All versions | 1.8.6 |

Products: Jenkins Libvirt Slaves.

## How do I fix CVE-2019-10472?

Upgrade org.jenkins-ci.plugins:libvirt-slave to 1.8.6 or later.

## Is CVE-2019-10472 being exploited?

There is no known exploitation of CVE-2019-10472 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Libvirt Slaves Plugin

- [CVE-2019-10471](https://insights.sbomify.com/CVE-2019-10471/): Jenkins Libvirt Slaves Plugin vlnerable to Cross-Site Request Forgery (high 8.8)
- [CVE-2019-10473](https://insights.sbomify.com/CVE-2019-10473/): Jenkins Libvirt Slaves Plugin vlnerable to Credential Enumeration (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-10472 and fix it if it is affected.

What it is: CVE-2019-10472 is a medium-severity missing authorization vulnerability in Jenkins Libvirt Slaves Plugin, published on 23 Oct 2019. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-10472 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:libvirt-slave (Maven): affected all versions; fixed in 1.8.6
- org.jenkins-ci.plugins:libvirt-slave (Maven): affected all versions; fixed in 1.8.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-10472/ (Markdown: https://insights.sbomify.com/CVE-2019-10472/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-10472
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-10472
- OSV: https://osv.dev/vulnerability/CVE-2019-10472

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-10472/
Summaries are generated and may contain mistakes; the official description above is the record.
