{"answers":{"affected":"2 open source packages ship an affected version, including org.jenkins-ci.plugins:libvirt-slave. It affects 1 product.","exploited":"There is no known exploitation of CVE-2019-10473 in the wild and no public exploit code.","fix":"Upgrade org.jenkins-ci.plugins:libvirt-slave to 1.8.6 or later.","what":"CVE-2019-10473 is a medium-severity missing authorization vulnerability in Jenkins Libvirt Slaves Plugin, published on 23 Oct 2019. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2019-10473 and fix it if it is affected.\n\nWhat it is: CVE-2019-10473 is a medium-severity missing authorization vulnerability in Jenkins Libvirt Slaves Plugin, published on 23 Oct 2019. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2019-10473 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jenkins-ci.plugins:libvirt-slave (Maven): affected all versions; fixed in 1.8.6\n- org.jenkins-ci.plugins:libvirt-slave (Maven): affected all versions; fixed in 1.8.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-10473/ (Markdown: https://insights.sbomify.com/CVE-2019-10473/index.md)","id":"CVE-2019-10473","markdown":"https://insights.sbomify.com/CVE-2019-10473/index.md","name":"CVE-2019-10473","record":{"aliases":["GHSA-8j3m-j6x6-cp5v"],"analysis":{"component_type":"cms_plugin","fix_type":"patch","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins Libvirt Plugin","requires_auth":"low_privilege","summary":"Users with read access can enumerate stored credential IDs due to missing permission checks in the Jenkins Libvirt Slaves Plugin.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jenkins","cpe":[{"product":"libvirt_slaves","vendor":"jenkins"}],"cvss":{"score":4.3,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-276","name":"Incorrect Default Permissions"}],"description":"A missing permission check in Jenkins Libvirt Slaves Plugin in form-related methods allowed users with Overall/Read access to enumerate credentials ID of credentials stored in Jenkins.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Jenkins Libvirt Slaves Plugin vlnerable to Credential Enumeration","id":"CVE-2019-10473","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"missing_authorization","year":"2019"},"n_packages":2,"n_references":2,"next":{"headline":"Jenkins Global Post Script Plugin missing permission check","id":"CVE-2019-10474"},"packages":[{"ecosystem":"Maven","fixed":["1.8.6"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:libvirt-slave","purl":null,"source":"GHSA-8j3m-j6x6-cp5v"},{"ecosystem":"Maven","fixed":["1.8.6"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:libvirt-slave","purl":"pkg:maven/org.jenkins-ci.plugins/libvirt-slave","source":"GHSA-8j3m-j6x6-cp5v"}],"prev":{"headline":"Jenkins Libvirt Slaves Plugin vlnerable to Incorrect Default Permissions","id":"CVE-2019-10472"},"products":["Jenkins Libvirt Slaves Plugin"],"published":"2019-10-23","related":[{"cvss_score":8.8,"headline":"Jenkins Libvirt Slaves Plugin vlnerable to Cross-Site Request Forgery","id":"CVE-2019-10471","kev_date_added":null,"published":"2019-10-23"},{"cvss_score":6.5,"headline":"Jenkins Libvirt Slaves Plugin vlnerable to Incorrect Default Permissions","id":"CVE-2019-10472","kev_date_added":null,"published":"2019-10-23"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["Jenkins project"]},"summary":"Users with read access can enumerate stored credential IDs due to missing permission checks in the Jenkins Libvirt Slaves Plugin.","url":"https://insights.sbomify.com/CVE-2019-10473/"}