# CVE-2019-10476: Jenkins Zulip Plugin vulnerable to Insufficiently Protected Credentials

> Attackers with master file system access can read unencrypted credentials stored by the Jenkins Zulip Plugin.

- **Severity:** High 7.8 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Oct 2019
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-hfjr-m75m-wmh7

## What is CVE-2019-10476?

CVE-2019-10476 is a high-severity vulnerability in Jenkins Zulip Plugin, published on 23 Oct 2019. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Jenkins Zulip Plugin 1.1.0 and earlier stored credentials unencrypted in its global configuration file on the Jenkins master where they could be viewed by users with access to the master file system.

Weakness: CWE-522 (Insufficiently Protected Credentials)

## Which versions are affected by CVE-2019-10476?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:zulip. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:zulip` | Maven | All versions | 1.1.1 |
| `org.jenkins-ci.plugins:zulip` | Maven | All versions | 1.1.1 |

Products: Jenkins Zulip.

## How do I fix CVE-2019-10476?

Upgrade org.jenkins-ci.plugins:zulip to 1.1.1 or later.

## Is CVE-2019-10476 being exploited?

There is no known exploitation of CVE-2019-10476 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-10476 and fix it if it is affected.

What it is: CVE-2019-10476 is a high-severity vulnerability in Jenkins Zulip Plugin, published on 23 Oct 2019. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-10476 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:zulip (Maven): affected all versions; fixed in 1.1.1
- org.jenkins-ci.plugins:zulip (Maven): affected all versions; fixed in 1.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-10476/ (Markdown: https://insights.sbomify.com/CVE-2019-10476/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-10476
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-10476
- OSV: https://osv.dev/vulnerability/CVE-2019-10476

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-10476/
Summaries are generated and may contain mistakes; the official description above is the record.
