CVE-2019-10641 Contao Does Not Invalidate Existing Sessions When Password Changes
Weak password recovery mechanism in Contao CMS allows attackers to bypass authentication and take over user accounts.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2019-10641?
CVE-2019-10641 is a critical authentication bypass vulnerability in n/a, published on 17 Apr 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Contao before 3.5.39 and 4.x before 4.7.3 has a Weak Password Recovery Mechanism for a Forgotten Password.
Weakness: CWE-640
Which versions are affected by CVE-2019-10641?
10 open source packages ship an affected version, including contao/contao, contao/core and contao/core-bundle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
contao/contao Packagist | From 4.0.0 | 4.4.37 |
contao/contao Packagist | From 4.0.0 | 4.4.37 |
contao/contao Packagist | From 4.5.0 | 4.7.3 |
contao/contao Packagist | From 4.5.0 | 4.7.3 |
contao/core Packagist | From 3.0.0 | 3.5.39 |
contao/core Packagist | From 3.0.0 | 3.5.39 |
4 more packages
contao/core-bundle Packagist | From 4.0.0 | 4.4.37 |
contao/core-bundle Packagist | From 4.0.0 | 4.4.37 |
contao/core-bundle Packagist | From 4.5.0 | 4.7.3 |
contao/core-bundle Packagist | From 4.5.0 | 4.7.3 |
Products include Contao Contao Cms.
How do I fix CVE-2019-10641?
Upgrade contao/contao to a fixed version for your release line: 4.4.37 or 4.7.3.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2019-10641 being exploited?
There is no known exploitation of CVE-2019-10641 in the wild and no public exploit code.
Other vulnerabilities in n/a
Sources
Also known as GHSA-vcgg-hp4r-87gx.