# CVE-2019-10641: Contao Does Not Invalidate Existing Sessions When Password Changes

> Weak password recovery mechanism in Contao CMS allows attackers to bypass authentication and take over user accounts.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Apr 2019
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-vcgg-hp4r-87gx

## What is CVE-2019-10641?

CVE-2019-10641 is a critical authentication bypass vulnerability in n/a, published on 17 Apr 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Contao before 3.5.39 and 4.x before 4.7.3 has a Weak Password Recovery Mechanism for a Forgotten Password.

Weakness: CWE-640 (Weak Password Recovery Mechanism for Forgotten Password)

## Which versions are affected by CVE-2019-10641?

10 open source packages ship an affected version, including contao/contao, contao/core and contao/core-bundle. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `contao/contao` | Packagist | From 4.0.0 | 4.4.37 |
| `contao/contao` | Packagist | From 4.0.0 | 4.4.37 |
| `contao/contao` | Packagist | From 4.5.0 | 4.7.3 |
| `contao/contao` | Packagist | From 4.5.0 | 4.7.3 |
| `contao/core` | Packagist | From 3.0.0 | 3.5.39 |
| `contao/core` | Packagist | From 3.0.0 | 3.5.39 |
| `contao/core-bundle` | Packagist | From 4.0.0 | 4.4.37 |
| `contao/core-bundle` | Packagist | From 4.0.0 | 4.4.37 |
| `contao/core-bundle` | Packagist | From 4.5.0 | 4.7.3 |
| `contao/core-bundle` | Packagist | From 4.5.0 | 4.7.3 |

Products: Contao Contao Cms.

## How do I fix CVE-2019-10641?

Upgrade contao/contao to a fixed version for your release line: 4.4.37 or 4.7.3.

## Is CVE-2019-10641 being exploited?

There is no known exploitation of CVE-2019-10641 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2014-1860](https://insights.sbomify.com/CVE-2014-1860/): Deserialization in n/a (critical 9.8)
- [CVE-2017-16558](https://insights.sbomify.com/CVE-2017-16558/): Contao SQL injection in the backend and listing module (critical 9.8)
- [CVE-2019-10643](https://insights.sbomify.com/CVE-2019-10643/): Contao Does Not Expire Tokens Correctly (critical 9.8)
- [CVE-2019-10642](https://insights.sbomify.com/CVE-2019-10642/): Contao CSRF Token Bypass (high 8.8)
- [CVE-2017-10993](https://insights.sbomify.com/CVE-2017-10993/): Contao Core directory traversal vulnerability (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-10641 and fix it if it is affected.

What it is: CVE-2019-10641 is a critical authentication bypass vulnerability in n/a, published on 17 Apr 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-10641 in the wild and no public exploit code.

Affected packages and fixed versions:
- contao/contao (Packagist): affected from 4.0.0; fixed in 4.4.37
- contao/contao (Packagist): affected from 4.0.0; fixed in 4.4.37
- contao/contao (Packagist): affected from 4.5.0; fixed in 4.7.3
- contao/contao (Packagist): affected from 4.5.0; fixed in 4.7.3
- contao/core (Packagist): affected from 3.0.0; fixed in 3.5.39
- contao/core (Packagist): affected from 3.0.0; fixed in 3.5.39
- contao/core-bundle (Packagist): affected from 4.0.0; fixed in 4.4.37
- contao/core-bundle (Packagist): affected from 4.0.0; fixed in 4.4.37
- contao/core-bundle (Packagist): affected from 4.5.0; fixed in 4.7.3
- contao/core-bundle (Packagist): affected from 4.5.0; fixed in 4.7.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-10641/ (Markdown: https://insights.sbomify.com/CVE-2019-10641/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-10641
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-10641
- OSV: https://osv.dev/vulnerability/CVE-2019-10641

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-10641/
Summaries are generated and may contain mistakes; the official description above is the record.
