CVE-2019-10642 Contao CSRF Token Bypass
High 8.8
Published
Updated
Check this codebase for CVE-2019-10642 and fix it if it is affected.
What it is: CVE-2019-10642 is a high-severity vulnerability in n/a, published on 17 Apr 2019.
Exploitation: There is no known exploitation of CVE-2019-10642 in the wild and no public exploit code.
Affected packages and fixed versions:
- contao/contao (Packagist): affected from 4.7.0; fixed in 4.7.3
- contao/contao (Packagist): affected from 4.7.0; fixed in 4.7.3
- contao/core-bundle (Packagist): affected from 4.7.0; fixed in 4.7.3
- contao/core-bundle (Packagist): affected from 4.7.0; fixed in 4.7.3
Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.
Reference: https://insights.sbomify.com/CVE-2019-10642/ (Markdown: https://insights.sbomify.com/CVE-2019-10642/index.md)
- Exploited in the wild
- Not known
- Fix
- Available
What is CVE-2019-10642?
CVE-2019-10642 is a high-severity vulnerability in n/a, published on 17 Apr 2019.
Official description
Contao 4.7 allows CSRF.
Weakness: CWE-352
Which versions are affected by CVE-2019-10642?
4 open source packages ship an affected version, including contao/contao and contao/core-bundle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
contao/contao Packagist | From 4.7.0 | 4.7.3 |
contao/contao Packagist | From 4.7.0 | 4.7.3 |
contao/core-bundle Packagist | From 4.7.0 | 4.7.3 |
contao/core-bundle Packagist | From 4.7.0 | 4.7.3 |
Products include Contao Contao Cms.
How do I fix CVE-2019-10642?
Upgrade contao/contao to 4.7.3 or later.
Is CVE-2019-10642 being exploited?
There is no known exploitation of CVE-2019-10642 in the wild and no public exploit code.
Other vulnerabilities in n/a
- CVE-2014-1860 Deserialization in n/a
- CVE-2017-16558 Contao SQL injection in the backend and listing module
- CVE-2019-10641 Contao Does Not Invalidate Existing Sessions When Password Changes
- CVE-2019-10643 Contao Does Not Expire Tokens Correctly
- CVE-2017-10993 Contao Core directory traversal vulnerability
Sources
Also known as GHSA-hwmh-9jj9-8c9c.