# CVE-2019-10648: Improper Input Validation in net.sf.robocode:robocode.host allows for external service interaction

> Remote attackers can trigger external DNS interactions via URL streams, potentially leaking information or bypassing network restrictions in Robocode.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Mar 2019
- **Updated:** 4 Aug 2024
- **Also known as:** DEBIAN-CVE-2019-10648, GHSA-q2xp-75m7-gv52, UBUNTU-CVE-2019-10648

## What is CVE-2019-10648?

CVE-2019-10648 is a critical server-side request forgery vulnerability in n/a, published on 30 Mar 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Robocode through 1.9.3.5 allows remote attackers to cause external service interaction (DNS), as demonstrated by a query for a unique subdomain name within an attacker-controlled DNS zone, because of a .openStream call within java.net.URL.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2019-10648?

2 open source packages ship an affected version, including net.sf.robocode:robocode.host. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `net.sf.robocode:robocode.host` | Maven | All versions | 1.9.3.7 |
| `net.sf.robocode:robocode.host` | Maven | All versions | 1.9.3.7 |

Products: Robocode Robocode.

## How do I fix CVE-2019-10648?

Upgrade net.sf.robocode:robocode.host to 1.9.3.7 or later.

## Is CVE-2019-10648 being exploited?

There is no known exploitation of CVE-2019-10648 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2025-14306](https://insights.sbomify.com/CVE-2025-14306/): Directory Traversal in Robocode's CacheCleaner Component (critical 10.0)
- [CVE-2025-14308](https://insights.sbomify.com/CVE-2025-14308/): Integer Overflow in Robocode's Buffer Write Method (critical 10.0)
- [CVE-2025-14307](https://insights.sbomify.com/CVE-2025-14307/): Insecure Temporary File Creation in Robocode's AutoExtract Component (critical 9.3)
- [CVE-2008-2078](https://insights.sbomify.com/CVE-2008-2078/): Other in n/a (high 7.5)
- [CVE-2007-6382](https://insights.sbomify.com/CVE-2007-6382/): Robocode Arbitrary Code Execution (medium 6.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-10648 and fix it if it is affected.

What it is: CVE-2019-10648 is a critical server-side request forgery vulnerability in n/a, published on 30 Mar 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-10648 in the wild and no public exploit code.

Affected packages and fixed versions:
- net.sf.robocode:robocode.host (Maven): affected all versions; fixed in 1.9.3.7
- net.sf.robocode:robocode.host (Maven): affected all versions; fixed in 1.9.3.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-10648/ (Markdown: https://insights.sbomify.com/CVE-2019-10648/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-10648
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-10648
- OSV: https://osv.dev/vulnerability/CVE-2019-10648

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-10648/
Summaries are generated and may contain mistakes; the official description above is the record.
