{"answers":{"affected":"2 open source packages ship an affected version, including librenms/librenms. It affects 1 product.","exploited":"There is no known exploitation of CVE-2019-10667 in the wild and no public exploit code.","fix":"Upgrade librenms/librenms to 1.50.1 or later.","what":"CVE-2019-10667 is a medium-severity vulnerability in Librenms Librenms, published on 9 Sep 2019. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2019-10667 and fix it if it is affected.\n\nWhat it is: CVE-2019-10667 is a medium-severity vulnerability in Librenms Librenms, published on 9 Sep 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2019-10667 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- librenms/librenms (Packagist): affected all versions; fixed in 1.50.1\n- librenms/librenms (Packagist): affected all versions; fixed in 1.50.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-10667/ (Markdown: https://insights.sbomify.com/CVE-2019-10667/index.md)","id":"CVE-2019-10667","markdown":"https://insights.sbomify.com/CVE-2019-10667/index.md","name":"CVE-2019-10667","record":{"aliases":["GHSA-f4hh-xxqh-wgpq"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Network monitoring system","requires_auth":"none","summary":"Attackers can fingerprint the installed code version and disclose local file paths in LibreNMS, potentially aiding further attacks.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"librenms","vendor":"librenms"}],"cvss":{"score":5.3,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"}],"description":"An issue was discovered in LibreNMS through 1.47. Information disclosure can occur: an attacker can fingerprint the exact code version installed and disclose local file paths.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Exposure of Sensitive Information to an Unauthorized Actor in LibreNMS","id":"CVE-2019-10667","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"librenms:librenms","products":["librenms:librenms"],"type":"information_disclosure","year":"2019"},"n_packages":2,"n_references":1,"next":{"headline":"Missing Authentication for Critical Function in LibreNMS","id":"CVE-2019-10668"},"packages":[{"ecosystem":"Packagist","fixed":["1.50.1"],"introduced":["0"],"last_affected":[],"package":"librenms/librenms","purl":null,"source":"GHSA-f4hh-xxqh-wgpq"},{"ecosystem":"Packagist","fixed":["1.50.1"],"introduced":["0"],"last_affected":[],"package":"librenms/librenms","purl":"pkg:composer/librenms/librenms","source":"GHSA-f4hh-xxqh-wgpq"}],"prev":{"headline":"Code injection in n/a","id":"CVE-2019-10666"},"products":["n/a"],"published":"2019-09-09","related":[{"cvss_score":9.8,"headline":"Cross-site Scripting (XSS) - Stored in librenms/librenms","id":"CVE-2023-4982","kev_date_added":null,"published":"2023-09-15"},{"cvss_score":9.8,"headline":"Command injection in librenms","id":"CVE-2022-29712","kev_date_added":null,"published":"2022-05-31"},{"cvss_score":9.8,"headline":"Path traversal in librenms/librenms","id":"CVE-2021-44278","kev_date_added":null,"published":"2021-12-03"},{"cvss_score":9.8,"headline":"LibreNMS Information Disclosure","id":"CVE-2019-10665","kev_date_added":null,"published":"2019-09-09"},{"cvss_score":9.8,"headline":"LibreNMS arbitrary OS commands execution","id":"CVE-2018-20434","kev_date_added":null,"published":"2019-04-24"},{"cvss_score":9.3,"headline":"LibreNMS: SQL Injection in ajax_table.php spreads through a covert data stream","id":"CVE-2026-26988","kev_date_added":null,"published":"2026-02-20"},{"cvss_score":9.2,"headline":"LibreNMS before 26.8.0 Authentication Bypass via API Token Type Confusion","id":"CVE-2026-86426","kev_date_added":null,"published":"2026-09-07"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"Attackers can fingerprint the installed code version and disclose local file paths in LibreNMS, potentially aiding further attacks.","url":"https://insights.sbomify.com/CVE-2019-10667/"}