# CVE-2019-10742: Denial of Service in axios

> Attackers can crash applications using the Axios library by sending responses that exceed the configured maximum content length.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 May 2019
- **Updated:** 4 Aug 2024
- **Also known as:** DEBIAN-CVE-2019-10742, GHSA-42xw-2xvc-qx8m

## What is CVE-2019-10742?

CVE-2019-10742 is a high-severity denial of service vulnerability in axios, published on 7 May 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Axios up to and including 0.18.0 allows attackers to cause a denial of service (application crash) by continuing to accepting content after maxContentLength is exceeded.

Weakness: CWE-755 (Improper Handling of Exceptional Conditions)

## Which versions are affected by CVE-2019-10742?

2 open source packages ship an affected version, including axios. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `axios` | npm | All versions | 0.18.1 |
| `axios` | npm | All versions | 0.18.1 |

Products: Axios Axios.

## How do I fix CVE-2019-10742?

Upgrade axios to 0.18.1 or later.

## Is CVE-2019-10742 being exploited?

There is no known exploitation of CVE-2019-10742 in the wild and no public exploit code.

Public exploit code:

- https://github.com/Viniciuspxf/CVE-2019-10742 (github_poc): https://github.com/Viniciuspxf/CVE-2019-10742

## Other vulnerabilities in axios

- [CVE-2026-44494](https://insights.sbomify.com/CVE-2026-44494/): Axios: Full Man-in-the-Middle via Prototype Pollution Gadget in `config.proxy` (high 8.7)
- [CVE-2026-44492](https://insights.sbomify.com/CVE-2026-44492/): axios's shouldBypassProxy does not recognize IPv4-mapped IPv6 addresses, allowing NO_PROXY bypass (incomplete fix for CVE-2025-62718) (high 8.6)
- [CVE-2026-67320](https://insights.sbomify.com/CVE-2026-67320/): axios before 0.33.0 Prototype Pollution via Node HTTP adapter (high 8.3)
- [CVE-2026-44487](https://insights.sbomify.com/CVE-2026-44487/): Axios: Proxy-Authorization Credential Leak to Origin Server Across HTTP-to-HTTPS Redirect in Axios Node.js HTTP Adapter (high 8.2)
- [CVE-2025-27152](https://insights.sbomify.com/CVE-2025-27152/): Possible SSRF and Credential Leakage via Absolute URL in axios Requests (high 7.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-10742 and fix it if it is affected.

What it is: CVE-2019-10742 is a high-severity denial of service vulnerability in axios, published on 7 May 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-10742 in the wild and no public exploit code.

Affected packages and fixed versions:
- axios (npm): affected all versions; fixed in 0.18.1
- axios (npm): affected all versions; fixed in 0.18.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-10742/ (Markdown: https://insights.sbomify.com/CVE-2019-10742/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-10742
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-10742
- OSV: https://osv.dev/vulnerability/CVE-2019-10742

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-10742/
Summaries are generated and may contain mistakes; the official description above is the record.
