# CVE-2019-10744: Prototype Pollution in lodash

> Prototype pollution in lodash allows attackers to modify Object.prototype, potentially leading to code execution or privilege escalation.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Jul 2019
- **Updated:** 4 Aug 2024
- **Also known as:** AZL-44634, DEBIAN-CVE-2019-10744, GHSA-jf85-cpcp-j695, MINI-4jp3-85gc-3wgg, MINI-5xv2-6g9x-pw54, MINI-m42f-gh7w-8xj7, ROOT-APP-NPM-CVE-2019-10744, SNYK-JS-LODASH-450202

## What is CVE-2019-10744?

CVE-2019-10744 is a critical vulnerability in F5 Big-Ip Access Policy Manager, published on 25 Jul 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Versions of lodash lower than 4.17.12 are vulnerable to Prototype Pollution. The function defaultsDeep could be tricked into adding or modifying properties of Object.prototype using a constructor payload.

Weakness: CWE-1321 (Improperly Controlled Modification of Object Prototype Attributes)

## Which versions are affected by CVE-2019-10744?

10 open source packages ship an affected version, including lodash-rails, lodash and lodash-amd. It affects 21 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `lodash-rails` | RubyGems | All versions | 4.17.12 |
| `lodash-rails` | RubyGems | All versions | 4.17.12 |
| `lodash` | npm | All versions | 4.17.12 |
| `lodash` | npm | All versions | 4.17.12 |
| `lodash-amd` | npm | All versions | 4.17.13 |
| `lodash-amd` | npm | All versions | 4.17.13 |
| `lodash-es` | npm | All versions | 4.17.14 |
| `lodash-es` | npm | All versions | 4.17.14 |
| `lodash.defaultsdeep` | npm | All versions | 4.6.1 |
| `lodash.defaultsdeep` | npm | All versions | 4.6.1 |

Products: F5 Big-Ip Access Policy Manager, F5 Big-Ip Advanced Firewall Manager, F5 Big-Ip Analytics, F5 Big-Ip Application Acceleration Manager, F5 Big-Ip Application Security Manager, F5 Big-Ip Application Visibility and Reporting, F5 Big-Ip Domain Name System, F5 Big-Ip Edge Gateway, F5 Big-Ip Fraud Protection Service, F5 Big-Ip Global Traffic Manager, F5 Big-Ip Link Controller, F5 Big-Ip Local Traffic Manager, F5 Big-Ip Policy Enforcement Manager, F5 Big-Ip Webaccelerator, F5 Big-Iq Centralized Management, F5 Iworkflow, Lodash Lodash, Netapp Active Iq Unified Manager, Netapp Service Level Manager, Oracle Banking Extensibility Workbench and 1 more.

## How do I fix CVE-2019-10744?

Upgrade lodash-rails to 4.17.12 or later.

## Is CVE-2019-10744 being exploited?

There is no known exploitation of CVE-2019-10744 in the wild and no public exploit code.

Public exploit code:

- AURORA demo target — deliberately vulnerable lockfiles (CVE-2019-10744, CVE-2018-18074, CVE-2020-26160) (github_poc): https://github.com/mlbrilliance/aurora-demo-lockfile
- Thesis scenario test (research only): Scenario B: WARN path - lodash@4.17.4 CVE-2019-10744 (known-vulnerable dependency, low EPSS) (github_poc): https://github.com/jimahub/scenario-b-warn

## Other vulnerabilities in F5 Big-Ip Access Policy Manager

- [CVE-2023-46747](https://insights.sbomify.com/CVE-2023-46747/): F5 BIG-IP Configuration Utility Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2022-1388](https://insights.sbomify.com/CVE-2022-1388/): F5 BIG-IP Missing Authentication (critical 9.8, exploited in the wild)
- [CVE-2021-22986](https://insights.sbomify.com/CVE-2021-22986/): F5 BIG-IP and BIG-IQ Centralized Management iControl REST Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2021-22991](https://insights.sbomify.com/CVE-2021-22991/): F5 BIG-IP Traffic Management Microkernel Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2020-5902](https://insights.sbomify.com/CVE-2020-5902/): F5 BIG-IP Traffic Management User Interface (TMUI) Remote Code Execution (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-10744 and fix it if it is affected.

What it is: CVE-2019-10744 is a critical vulnerability in F5 Big-Ip Access Policy Manager, published on 25 Jul 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-10744 in the wild and no public exploit code.

Affected packages and fixed versions:
- lodash-rails (RubyGems): affected all versions; fixed in 4.17.12
- lodash-rails (RubyGems): affected all versions; fixed in 4.17.12
- lodash (npm): affected all versions; fixed in 4.17.12
- lodash (npm): affected all versions; fixed in 4.17.12
- lodash-amd (npm): affected all versions; fixed in 4.17.13
- lodash-amd (npm): affected all versions; fixed in 4.17.13
- lodash-es (npm): affected all versions; fixed in 4.17.14
- lodash-es (npm): affected all versions; fixed in 4.17.14
- lodash.defaultsdeep (npm): affected all versions; fixed in 4.6.1
- lodash.defaultsdeep (npm): affected all versions; fixed in 4.6.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-10744/ (Markdown: https://insights.sbomify.com/CVE-2019-10744/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-10744
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-10744
- OSV: https://osv.dev/vulnerability/CVE-2019-10744

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-10744/
Summaries are generated and may contain mistakes; the official description above is the record.
