# CVE-2019-10745: assign-deep Vulnerable to Prototype Pollution

> Prototype pollution in assign-deep allows attackers to modify Object.prototype, potentially leading to code execution or privilege escalation.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Aug 2019
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-66rh-8fw6-59q6

## What is CVE-2019-10745?

CVE-2019-10745 is a high-severity vulnerability in assign-deep, published on 20 Aug 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

assign-deep is vulnerable to Prototype Pollution in versions before 0.4.8 and version 1.0.0. The function assign-deep could be tricked into adding or modifying properties of Object.prototype using either a constructor or a _proto_ payload.

Weakness: CWE-1321 (Improperly Controlled Modification of Object Prototype Attributes)

## Which versions are affected by CVE-2019-10745?

4 open source packages ship an affected version, including assign-deep. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `assign-deep` | npm | All versions | 0.4.8 |
| `assign-deep` | npm | All versions | 0.4.8 |
| `assign-deep` | npm | From 1.0.0 | 1.0.1 |
| `assign-deep` | npm | From 1.0.0 | 1.0.1 |

Products: Assign-Deep Project Assign-Deep.

## How do I fix CVE-2019-10745?

Upgrade assign-deep to a fixed version for your release line: 0.4.8 or 1.0.1.

## Is CVE-2019-10745 being exploited?

There is no known exploitation of CVE-2019-10745 in the wild and no public exploit code.

## Other vulnerabilities in assign-deep

- [CVE-2018-3720](https://insights.sbomify.com/CVE-2018-3720/): Prototype Pollution in assign-deep (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-10745 and fix it if it is affected.

What it is: CVE-2019-10745 is a high-severity vulnerability in assign-deep, published on 20 Aug 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-10745 in the wild and no public exploit code.

Affected packages and fixed versions:
- assign-deep (npm): affected all versions; fixed in 0.4.8
- assign-deep (npm): affected all versions; fixed in 0.4.8
- assign-deep (npm): affected from 1.0.0; fixed in 1.0.1
- assign-deep (npm): affected from 1.0.0; fixed in 1.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-10745/ (Markdown: https://insights.sbomify.com/CVE-2019-10745/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-10745
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-10745
- OSV: https://osv.dev/vulnerability/CVE-2019-10745

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-10745/
Summaries are generated and may contain mistakes; the official description above is the record.
