# CVE-2019-10747: Prototype Pollution in set-value

> Prototype pollution in set-value allows attackers to modify Object.prototype, potentially leading to code execution or privilege escalation.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Aug 2019
- **Updated:** 4 Aug 2024
- **Also known as:** DEBIAN-CVE-2019-10747, GHSA-4g88-fppr-53pp, MGASA-2020-0230, SNYK-JS-SETVALUE-450213, UBUNTU-CVE-2019-10747

## What is CVE-2019-10747?

CVE-2019-10747 is a critical vulnerability in set-value, published on 23 Aug 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

set-value is vulnerable to Prototype Pollution in versions lower than 3.0.1. The function mixin-deep could be tricked into adding or modifying properties of Object.prototype using any of the constructor, prototype and _proto_ payloads.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2019-10747?

4 open source packages ship an affected version, including set-value. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `set-value` | npm | All versions | 2.0.1 |
| `set-value` | npm | All versions | 2.0.1 |
| `set-value` | npm | From 3.0.0 | 3.0.1 |
| `set-value` | npm | From 3.0.0 | 3.0.1 |

Products: Set-Value Project Set-Value.

## How do I fix CVE-2019-10747?

Upgrade set-value to a fixed version for your release line: 2.0.1 or 3.0.1.

## Is CVE-2019-10747 being exploited?

There is no known exploitation of CVE-2019-10747 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-10747 and fix it if it is affected.

What it is: CVE-2019-10747 is a critical vulnerability in set-value, published on 23 Aug 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-10747 in the wild and no public exploit code.

Affected packages and fixed versions:
- set-value (npm): affected all versions; fixed in 2.0.1
- set-value (npm): affected all versions; fixed in 2.0.1
- set-value (npm): affected from 3.0.0; fixed in 3.0.1
- set-value (npm): affected from 3.0.0; fixed in 3.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-10747/ (Markdown: https://insights.sbomify.com/CVE-2019-10747/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-10747
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-10747
- OSV: https://osv.dev/vulnerability/CVE-2019-10747

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-10747/
Summaries are generated and may contain mistakes; the official description above is the record.
