# CVE-2019-10751: Open Redirect in httpie

> An attacker can exploit an open redirect in HTTPie to write arbitrary files to the current directory by redirecting requests to a malicious server.

- **Severity:** High 8.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 23 Aug 2019
- **Updated:** 4 Aug 2024
- **Also known as:** DEBIAN-CVE-2019-10751, DLA-1937-1, GHSA-xjjg-vmw6-c2p9, MGASA-2019-0351, PYSEC-2019-23, SNYK-PYTHON-HTTPIE-460107, UBUNTU-CVE-2019-10751, openSUSE-SU-2019:2050-1, openSUSE-SU-2019:2089-1, openSUSE-SU-2024:10849-1

## What is CVE-2019-10751?

CVE-2019-10751 is a high-severity vulnerability in HTTPIE, published on 23 Aug 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

All versions of the HTTPie package prior to version 1.0.3 are vulnerable to Open Redirect that allows an attacker to write an arbitrary file with supplied filename and content to the current directory, by redirecting a request from HTTP to a crafted URL pointing to a server in his or hers control.

Weakness: CWE-601 (URL Redirection to Untrusted Site)

## Which versions are affected by CVE-2019-10751?

3 open source packages ship an affected version, including httpie. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `httpie` | PyPI | All versions | 1.0.3 |
| `httpie` | PyPI | All versions | 1.0.3 |
| `httpie` | PyPI | All versions | 1.0.3 |
| `httpie` | SUSE:Package Hub 15 SP1 | All versions | 1.0.3-bp151.2.3.1 |
| `httpie` | SUSE:Package Hub 15 SP1 | All versions | 1.0.3-bp151.2.6.1 |
| `httpie` | openSUSE:Leap 15.1 | All versions | 1.0.3-bp151.2.3.1 |
| `httpie` | openSUSE:Tumbleweed | All versions | 2.5.0-1.2 |

Products: Httpie Httpie.

## How do I fix CVE-2019-10751?

Upgrade httpie to 1.0.3 or later.

## Is CVE-2019-10751 being exploited?

There is no known exploitation of CVE-2019-10751 in the wild and no public exploit code.

## Other vulnerabilities in HTTPIE

- [CVE-2023-48052](https://insights.sbomify.com/CVE-2023-48052/): HTTPie allows attackers to eavesdrop on communications between the host and server via a man-in-the-middle attack (high 7.4)
- [CVE-2022-0430](https://insights.sbomify.com/CVE-2022-0430/): Exposure of Sensitive Information to an Unauthorized Actor in httpie/httpie (low 2.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-10751 and fix it if it is affected.

What it is: CVE-2019-10751 is a high-severity vulnerability in HTTPIE, published on 23 Aug 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2019-10751 in the wild and no public exploit code.

Affected packages and fixed versions:
- httpie (PyPI): affected all versions; fixed in 1.0.3
- httpie (PyPI): affected all versions; fixed in 1.0.3
- httpie (PyPI): affected all versions; fixed in 1.0.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-10751/ (Markdown: https://insights.sbomify.com/CVE-2019-10751/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-10751
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-10751
- OSV: https://osv.dev/vulnerability/CVE-2019-10751

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-10751/
Summaries are generated and may contain mistakes; the official description above is the record.
