# CVE-2019-10753: Incorrect Resource Transfer Between Spheres in eclipse-wtp

> Attackers can perform Man-in-the-Middle attacks during builds to compromise artifacts, potentially affecting developers using Spotless.

- **Severity:** Medium 5.9 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Sep 2019
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-gvxv-5fp2-358q, SNYK-JAVA-COMDIFFPLUGSPOTLESS-460377, UBUNTU-CVE-2019-10753

## What is CVE-2019-10753?

CVE-2019-10753 is a medium-severity vulnerability in Spotless, published on 5 Sep 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In all versions prior to version 3.9.6 for eclipse-wtp, all versions prior to version 9.4.4 for eclipse-cdt, and all versions prior to version 3.0.1 for eclipse-groovy, Spotless was resolving dependencies over an insecure channel (http). If the build occurred over an insecure connection, a malicious user could have perform a Man-in-the-Middle attack during the build and alter the build artifacts that were produced. In case that any of these artifacts were compromised, any developers using these could be altered. **Note:** In order to validate that this artifact was not compromised, the maintainer would need to confirm that none of the artifacts published to the registry were not altered with. Until this happens, we can not guarantee that this artifact was not compromised even though the probability that this happened is low.

Weakness: CWE-669 (Incorrect Resource Transfer Between Spheres)

## Which versions are affected by CVE-2019-10753?

6 open source packages ship an affected version, including com.diffplug.spotless:spotless-eclipse-cdt, com.diffplug.spotless:spotless-eclipse-groovy and com.diffplug.spotless:spotless-eclipse-wtp. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.diffplug.spotless:spotless-eclipse-cdt` | Maven | All versions | 9.4.4 |
| `com.diffplug.spotless:spotless-eclipse-cdt` | Maven | All versions | 9.4.4 |
| `com.diffplug.spotless:spotless-eclipse-groovy` | Maven | All versions | 3.0.1 |
| `com.diffplug.spotless:spotless-eclipse-groovy` | Maven | All versions | 3.0.1 |
| `com.diffplug.spotless:spotless-eclipse-wtp` | Maven | All versions | 3.9.6 |
| `com.diffplug.spotless:spotless-eclipse-wtp` | Maven | All versions | 3.9.6 |

Products: Diffplug Eclipse-Cdt, Diffplug Eclipse-Groovy, Diffplug Eclipse-Wtp.

## How do I fix CVE-2019-10753?

Upgrade com.diffplug.spotless:spotless-eclipse-cdt to 9.4.4 or later.

## Is CVE-2019-10753 being exploited?

There is no known exploitation of CVE-2019-10753 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-10753 and fix it if it is affected.

What it is: CVE-2019-10753 is a medium-severity vulnerability in Spotless, published on 5 Sep 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-10753 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.diffplug.spotless:spotless-eclipse-cdt (Maven): affected all versions; fixed in 9.4.4
- com.diffplug.spotless:spotless-eclipse-cdt (Maven): affected all versions; fixed in 9.4.4
- com.diffplug.spotless:spotless-eclipse-groovy (Maven): affected all versions; fixed in 3.0.1
- com.diffplug.spotless:spotless-eclipse-groovy (Maven): affected all versions; fixed in 3.0.1
- com.diffplug.spotless:spotless-eclipse-wtp (Maven): affected all versions; fixed in 3.9.6
- com.diffplug.spotless:spotless-eclipse-wtp (Maven): affected all versions; fixed in 3.9.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-10753/ (Markdown: https://insights.sbomify.com/CVE-2019-10753/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-10753
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-10753
- OSV: https://osv.dev/vulnerability/CVE-2019-10753

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-10753/
Summaries are generated and may contain mistakes; the official description above is the record.
