# CVE-2019-10757: SQL Injection in knex

> Attackers can execute arbitrary SQL commands via crafted identifiers in MSSQL queries, potentially reading or modifying database contents.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Oct 2019
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-58v4-qwx5-7f59, SNYK-JS-KNEX-471962

## What is CVE-2019-10757?

CVE-2019-10757 is a critical SQL injection vulnerability in knex.js, published on 8 Oct 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

knex.js versions before 0.19.5 are vulnerable to SQL Injection attack. Identifiers are escaped incorrectly as part of the MSSQL dialect, allowing attackers to craft a malicious query to the host DB.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2019-10757?

2 open source packages ship an affected version, including knex. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `knex` | npm | All versions | 0.19.5 |
| `knex` | npm | All versions | 0.19.5 |

Products: Knexjs Knex.

## How do I fix CVE-2019-10757?

Upgrade knex to 0.19.5 or later.

## Is CVE-2019-10757 being exploited?

There is no known exploitation of CVE-2019-10757 in the wild and no public exploit code.

## Other vulnerabilities in knex.js

- [CVE-2016-20018](https://insights.sbomify.com/CVE-2016-20018/): Knex.js has a limited SQL injection vulnerability (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-10757 and fix it if it is affected.

What it is: CVE-2019-10757 is a critical SQL injection vulnerability in knex.js, published on 8 Oct 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-10757 in the wild and no public exploit code.

Affected packages and fixed versions:
- knex (npm): affected all versions; fixed in 0.19.5
- knex (npm): affected all versions; fixed in 0.19.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-10757/ (Markdown: https://insights.sbomify.com/CVE-2019-10757/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-10757
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-10757
- OSV: https://osv.dev/vulnerability/CVE-2019-10757

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-10757/
Summaries are generated and may contain mistakes; the official description above is the record.
