# CVE-2019-10758: MongoDB mongo-express Remote Code Execution

> Attackers can execute arbitrary code via the toBSON method in mongo-express due to unsafe vm usage, requiring an upgrade to secure the application.

- **Severity:** Critical 9.9 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Yes, since 10 Dec 2021 (CISA KEV)
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Dec 2019
- **Updated:** 21 Oct 2025
- **Also known as:** GHSA-h47j-hc6x-h3qq, SNYK-JS-MONGOEXPRESS-473215

## What is CVE-2019-10758?

CVE-2019-10758 is a critical code injection vulnerability in mongo-express, published on 24 Dec 2019. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

mongo-express before 0.54.0 is vulnerable to Remote Code Execution via endpoints that uses the `toBSON` method. A misuse of the `vm` dependency to perform `exec` commands in a non-safe environment.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2019-10758?

2 open source packages ship an affected version, including mongo-express. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mongo-express` | npm | All versions | 0.54.0 |
| `mongo-express` | npm | All versions | 0.54.0 |

Products: Mongo-Express Project Mongo-Express.

## How do I fix CVE-2019-10758?

Upgrade mongo-express to 0.54.0 or later. US federal agencies must fix it by 10 Jun 2022.

## Is CVE-2019-10758 being exploited?

Yes. Attackers have exploited CVE-2019-10758 in the wild since at least 10 Dec 2021.

Public exploit code:

- https://github.com/masahiro331/CVE-2019-10758 (github_poc): https://github.com/masahiro331/CVE-2019-10758
- CVE-2019-10758 (github_poc): https://github.com/lp008/CVE-2019-10758
- Vulhub mongo-express/CVE-2019-10758: mongo-express Remote Code Execution (CVE-2019-10758), run with Isoloom (github_poc): https://github.com/CyberCTF/vulhub-mongo-express-cve-2019-10758
- mongo-express Remote Code Execution (nuclei): http/cves/2019/CVE-2019-10758.yaml

## Other vulnerabilities in mongo-express

- [CVE-2020-24391](https://insights.sbomify.com/CVE-2020-24391/): Remote code execution in mongo-express (critical 9.8)
- [CVE-2021-21422](https://insights.sbomify.com/CVE-2021-21422/): XSS Vulnerability in mongo-express (high 8.1)
- [CVE-2023-52555](https://insights.sbomify.com/CVE-2023-52555/): mongo-express Cross-site Request Forgery vulnerability (medium 6.1)
- [CVE-2021-23372](https://insights.sbomify.com/CVE-2021-23372/): Denial of Service (DoS) (medium 4.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-10758 and fix it if it is affected.

What it is: CVE-2019-10758 is a critical code injection vulnerability in mongo-express, published on 24 Dec 2019. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: Yes. Attackers have exploited CVE-2019-10758 in the wild since at least 10 Dec 2021.

Affected packages and fixed versions:
- mongo-express (npm): affected all versions; fixed in 0.54.0
- mongo-express (npm): affected all versions; fixed in 0.54.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-10758/ (Markdown: https://insights.sbomify.com/CVE-2019-10758/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-10758
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-10758
- OSV: https://osv.dev/vulnerability/CVE-2019-10758

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-10758/
Summaries are generated and may contain mistakes; the official description above is the record.
