# CVE-2019-10759: Sandbox Breakout / Arbitrary Code Execution in safer-eval


- **Severity:** Critical 9.9 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 15 Oct 2019
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-r3x4-wr4h-pw33, SNYK-JS-SAFEREVAL-173772

## What is CVE-2019-10759?

CVE-2019-10759 is a critical vulnerability in Snyk safer-eval, published on 15 Oct 2019. 

### Official description

safer-eval before 1.3.4 are vulnerable to Arbitrary Code Execution. A payload using constructor properties can escape the sandbox and execute arbitrary code.

## Which versions are affected by CVE-2019-10759?

2 open source packages ship an affected version, including safer-eval. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `safer-eval` | npm | All versions | 1.3.4 |
| `safer-eval` | npm | All versions | 1.3.4 |

Products: Safer-Eval Project Safer-Eval.

## How do I fix CVE-2019-10759?

Upgrade safer-eval to 1.3.4 or later.

## Is CVE-2019-10759 being exploited?

There is no known exploitation of CVE-2019-10759 in the wild and no public exploit code.

## Other vulnerabilities in Snyk safer-eval

- [CVE-2019-10760](https://insights.sbomify.com/CVE-2019-10760/): Sandbox Breakout / Arbitrary Code Execution in safer-eval (critical 9.9)
- [CVE-2019-10769](https://insights.sbomify.com/CVE-2019-10769/): Sandbox Breakout / Arbitrary Code Execution in safer-eval (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-10759 and fix it if it is affected.

What it is: CVE-2019-10759 is a critical vulnerability in Snyk safer-eval, published on 15 Oct 2019. 
Exploitation: There is no known exploitation of CVE-2019-10759 in the wild and no public exploit code.

Affected packages and fixed versions:
- safer-eval (npm): affected all versions; fixed in 1.3.4
- safer-eval (npm): affected all versions; fixed in 1.3.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-10759/ (Markdown: https://insights.sbomify.com/CVE-2019-10759/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-10759
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-10759
- OSV: https://osv.dev/vulnerability/CVE-2019-10759

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-10759/
Summaries are generated and may contain mistakes; the official description above is the record.
