# CVE-2019-10760: Sandbox Breakout / Arbitrary Code Execution in safer-eval

> Attackers can escape the safer-eval sandbox to execute arbitrary code via constructor properties, impacting applications using this JavaScript library.

- **Severity:** Critical 9.9 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Oct 2019
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-hgch-jjmr-gp7w, SNYK-JS-SAFEREVAL-473029

## What is CVE-2019-10760?

CVE-2019-10760 is a critical code injection vulnerability in Snyk safer-eval, published on 15 Oct 2019. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

safer-eval before 1.3.2 are vulnerable to Arbitrary Code Execution. A payload using constructor properties can escape the sandbox and execute arbitrary code.

## Which versions are affected by CVE-2019-10760?

2 open source packages ship an affected version, including safer-eval. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `safer-eval` | npm | All versions | 1.3.2 |
| `safer-eval` | npm | All versions | 1.3.2 |

Products: Safer-Eval Project Safer-Eval.

## How do I fix CVE-2019-10760?

Upgrade safer-eval to 1.3.2 or later.

## Is CVE-2019-10760 being exploited?

There is no known exploitation of CVE-2019-10760 in the wild and no public exploit code.

Public exploit code:

- Publicly disclosed Proof-of-Concept (POC) exploit for the safer-eval@1.3.1 version (github_poc): https://github.com/lirantal/safer-eval-cve-CVE-2019-10760

## Other vulnerabilities in Snyk safer-eval

- [CVE-2019-10759](https://insights.sbomify.com/CVE-2019-10759/): Sandbox Breakout / Arbitrary Code Execution in safer-eval (critical 9.9)
- [CVE-2019-10769](https://insights.sbomify.com/CVE-2019-10769/): Sandbox Breakout / Arbitrary Code Execution in safer-eval (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-10760 and fix it if it is affected.

What it is: CVE-2019-10760 is a critical code injection vulnerability in Snyk safer-eval, published on 15 Oct 2019. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-10760 in the wild and no public exploit code.

Affected packages and fixed versions:
- safer-eval (npm): affected all versions; fixed in 1.3.2
- safer-eval (npm): affected all versions; fixed in 1.3.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-10760/ (Markdown: https://insights.sbomify.com/CVE-2019-10760/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-10760
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-10760
- OSV: https://osv.dev/vulnerability/CVE-2019-10760

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-10760/
Summaries are generated and may contain mistakes; the official description above is the record.
