# CVE-2019-10761: Sandbox Bypass

> Attackers can bypass the vm2 sandbox via stack overflow to access host modules and execute arbitrary code on the server.

- **Severity:** High 8.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:L/E:P/RL:O/RC:C`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Jul 2022
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-wf5x-cr3r-xr77, SNYK-JS-VM2-473188

## What is CVE-2019-10761?

CVE-2019-10761 is a high-severity code injection vulnerability in vm2, published on 13 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

This affects the package vm2 before 3.6.11. It is possible to trigger a RangeError exception from the host rather than the "sandboxed" context by reaching the stack call limit with an infinite recursion. The returned object is then used to reference the mainModule property of the host code running the script allowing it to spawn a child_process and execute arbitrary code.

Weakness: CWE-674 (Uncontrolled Recursion)

## Which versions are affected by CVE-2019-10761?

2 open source packages ship an affected version, including vm2. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vm2` | npm | All versions | 3.6.11 |
| `vm2` | npm | All versions | 3.6.11 |

Products: Vm2 Project Vm2.

## How do I fix CVE-2019-10761?

Upgrade vm2 to 3.6.11 or later.

## Is CVE-2019-10761 being exploited?

There is no known exploitation of CVE-2019-10761 in the wild and no public exploit code.

## Other vulnerabilities in vm2

- [CVE-2026-43997](https://insights.sbomify.com/CVE-2026-43997/): vm2: Sandbox Escape (critical 10.0)
- [CVE-2026-44005](https://insights.sbomify.com/CVE-2026-44005/): vm2: Sandbox escape (critical 10.0)
- [CVE-2026-44006](https://insights.sbomify.com/CVE-2026-44006/): vm2: Sandbox Escape (critical 10.0)
- [CVE-2023-29017](https://insights.sbomify.com/CVE-2023-29017/): vm2 Sandbox Escape vulnerability (critical 10.0)
- [CVE-2022-36067](https://insights.sbomify.com/CVE-2022-36067/): vm2 vulnerable to Sandbox Escape before v3.9.11 (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-10761 and fix it if it is affected.

What it is: CVE-2019-10761 is a high-severity code injection vulnerability in vm2, published on 13 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-10761 in the wild and no public exploit code.

Affected packages and fixed versions:
- vm2 (npm): affected all versions; fixed in 3.6.11
- vm2 (npm): affected all versions; fixed in 3.6.11

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-10761/ (Markdown: https://insights.sbomify.com/CVE-2019-10761/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-10761
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-10761
- OSV: https://osv.dev/vulnerability/CVE-2019-10761

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-10761/
Summaries are generated and may contain mistakes; the official description above is the record.
