# CVE-2019-10764: Timing attacks might allow practical recovery of the long-term private key

> Timing attacks in elliptic-php may leak scalar bit-length, enabling practical recovery of long-term private keys.

- **Severity:** High 7.4 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Nov 2019
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-mr6r-82x4-f4jj, SNYK-PHP-SIMPLITOELLIPTICPHP-534576

## What is CVE-2019-10764?

CVE-2019-10764 is a high-severity vulnerability in simplito/elliptic-php, published on 18 Nov 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In elliptic-php versions priot to 1.0.6, Timing attacks might be possible which can result in practical recovery of the long-term private key generated by the library under certain conditions. Leakage of a bit-length of the scalar during scalar multiplication is possible on an elliptic curve which might allow practical recovery of the long-term private key.

Weakness: CWE-203 (Observable Discrepancy)

## Which versions are affected by CVE-2019-10764?

2 open source packages ship an affected version, including simplito/elliptic-php. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `simplito/elliptic-php` | Packagist | All versions | 1.0.6 |
| `simplito/elliptic-php` | Packagist | All versions | 1.0.6 |

Products: Simplito Elliptic-Php.

## How do I fix CVE-2019-10764?

Upgrade simplito/elliptic-php to 1.0.6 or later.

## Is CVE-2019-10764 being exploited?

There is no known exploitation of CVE-2019-10764 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-10764 and fix it if it is affected.

What it is: CVE-2019-10764 is a high-severity vulnerability in simplito/elliptic-php, published on 18 Nov 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-10764 in the wild and no public exploit code.

Affected packages and fixed versions:
- simplito/elliptic-php (Packagist): affected all versions; fixed in 1.0.6
- simplito/elliptic-php (Packagist): affected all versions; fixed in 1.0.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-10764/ (Markdown: https://insights.sbomify.com/CVE-2019-10764/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-10764
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-10764
- OSV: https://osv.dev/vulnerability/CVE-2019-10764

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-10764/
Summaries are generated and may contain mistakes; the official description above is the record.
