# CVE-2019-10767: Arbitrary File Write in iobroker.js-controller

> An attacker can read files outside the intended directory via the admin panel, exposing sensitive data if authentication is disabled or bypassed.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Nov 2019
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-cmch-296j-wfvw, SNYK-JS-IOBROKERJSCONTROLLER-534881

## What is CVE-2019-10767?

CVE-2019-10767 is a high-severity path traversal vulnerability in iobroker.js-controller, published on 21 Nov 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An attacker can include file contents from outside the `/adapter/xxx/` directory, where `xxx` is the name of an existent adapter like "admin". It is exploited using the administrative web panel with a request for an adapter file. **Note:** The attacker has to be logged in if the authentication is enabled (by default isn't enabled).

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2019-10767?

2 open source packages ship an affected version, including iobroker.js-controller. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `iobroker.js-controller` | npm | All versions | 2.0.25 |
| `iobroker.js-controller` | npm | All versions | 2.0.25 |

Products: Iobroker Iobroker.js-Controller.

## How do I fix CVE-2019-10767?

Upgrade iobroker.js-controller to 2.0.25 or later.

## Is CVE-2019-10767 being exploited?

There is no known exploitation of CVE-2019-10767 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-10767 and fix it if it is affected.

What it is: CVE-2019-10767 is a high-severity path traversal vulnerability in iobroker.js-controller, published on 21 Nov 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-10767 in the wild and no public exploit code.

Affected packages and fixed versions:
- iobroker.js-controller (npm): affected all versions; fixed in 2.0.25
- iobroker.js-controller (npm): affected all versions; fixed in 2.0.25

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-10767/ (Markdown: https://insights.sbomify.com/CVE-2019-10767/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-10767
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-10767
- OSV: https://osv.dev/vulnerability/CVE-2019-10767

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-10767/
Summaries are generated and may contain mistakes; the official description above is the record.
