# CVE-2019-10770: Default development error handler in Ratpack is vulnerable to HTML content injection (XSS)

> Attackers can execute arbitrary scripts via XSS in Ratpack's development mode error handler if untrusted data is present in exception messages.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 28 Jan 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-r2wf-q3x4-hrv9

## What is CVE-2019-10770?

CVE-2019-10770 is a medium-severity cross-site scripting vulnerability in io.ratpack:ratpack-core, published on 28 Jan 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

All versions of io.ratpack:ratpack-core from 0.9.10 inclusive and before 1.7.6 are vulnerable to Cross-site Scripting (XSS). This affects the development mode error handler when an exception message contains untrusted data. Note the production mode error handler is not vulnerable - so for this to be utilized in production it would require users to not disable development mode.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2019-10770?

2 open source packages ship an affected version, including io.ratpack:ratpack-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.ratpack:ratpack-core` | Maven | All versions | 1.7.6 |
| `io.ratpack:ratpack-core` | Maven | All versions | 1.7.6 |

Products: Ratpack Ratpack.

## How do I fix CVE-2019-10770?

Upgrade io.ratpack:ratpack-core to 1.7.6 or later.

## Is CVE-2019-10770 being exploited?

There is no known exploitation of CVE-2019-10770 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-10770 and fix it if it is affected.

What it is: CVE-2019-10770 is a medium-severity cross-site scripting vulnerability in io.ratpack:ratpack-core, published on 28 Jan 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2019-10770 in the wild and no public exploit code.

Affected packages and fixed versions:
- io.ratpack:ratpack-core (Maven): affected all versions; fixed in 1.7.6
- io.ratpack:ratpack-core (Maven): affected all versions; fixed in 1.7.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-10770/ (Markdown: https://insights.sbomify.com/CVE-2019-10770/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-10770
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-10770
- OSV: https://osv.dev/vulnerability/CVE-2019-10770

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-10770/
Summaries are generated and may contain mistakes; the official description above is the record.
