{"answers":{"affected":"2 open source packages ship an affected version, including mikehaertl/php-shellcommand. It affects 1 product.","exploited":"There is no known exploitation of CVE-2019-10774 in the wild and no public exploit code.","fix":"Upgrade mikehaertl/php-shellcommand to 1.6.1 or later.","what":"CVE-2019-10774 is a critical command injection vulnerability in php-shellcommand, published on 30 Dec 2019. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2019-10774 and fix it if it is affected.\n\nWhat it is: CVE-2019-10774 is a critical command injection vulnerability in php-shellcommand, published on 30 Dec 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2019-10774 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- mikehaertl/php-shellcommand (Packagist): affected all versions; fixed in 1.6.1\n- mikehaertl/php-shellcommand (Packagist): affected all versions; fixed in 1.6.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-10774/ (Markdown: https://insights.sbomify.com/CVE-2019-10774/index.md)","id":"CVE-2019-10774","markdown":"https://insights.sbomify.com/CVE-2019-10774/index.md","name":"CVE-2019-10774","record":{"aliases":["DEBIAN-CVE-2019-10774","GHSA-c7fv-wv9f-cgjw","SNYK-PHP-MIKEHAERTLPHPSHELLCOMMAND-538426"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"PHP shell command library","requires_auth":"none","summary":"Attackers can execute arbitrary code via command injection in the php-shellcommand library, requiring an upgrade to secure the application.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"snyk","cpe":[{"product":"php-shellcommand","vendor":"php-shellcommand_project"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-78","name":"Improper Neutralization of Special Elements used in an OS Command"}],"description":"php-shellcommand versions before 1.6.1 have a command injection vulnerability. Successful exploitation could lead to arbitrary code execution.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"php-shellcommand command injection vulnerability","id":"CVE-2019-10774","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"command_injection","year":"2019"},"n_packages":2,"n_references":1,"next":{"headline":"Denial of Service in ecstatic","id":"CVE-2019-10775"},"packages":[{"ecosystem":"Packagist","fixed":["1.6.1"],"introduced":["0"],"last_affected":[],"package":"mikehaertl/php-shellcommand","purl":null,"source":"GHSA-c7fv-wv9f-cgjw"},{"ecosystem":"Packagist","fixed":["1.6.1"],"introduced":["0"],"last_affected":[],"package":"mikehaertl/php-shellcommand","purl":"pkg:composer/mikehaertl/php-shellcommand","source":"GHSA-c7fv-wv9f-cgjw"}],"prev":{"headline":"Yarn Improper link resolution before file access (Link Following)","id":"CVE-2019-10773"},"products":["php-shellcommand"],"published":"2019-12-30","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"Attackers can execute arbitrary code via command injection in the php-shellcommand library, requiring an upgrade to secure the application.","url":"https://insights.sbomify.com/CVE-2019-10774/"}