{"answers":{"affected":"2 open source packages ship an affected version, including ecstatic. It affects 1 product.","exploited":"There is no known exploitation of CVE-2019-10775 in the wild and no public exploit code.","fix":"Upgrade ecstatic to 4.1.3 or later.","what":"CVE-2019-10775 is a high-severity denial of service vulnerability in ecstatic, published on 2 Jan 2020. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2019-10775 and fix it if it is affected.\n\nWhat it is: CVE-2019-10775 is a high-severity denial of service vulnerability in ecstatic, published on 2 Jan 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2019-10775 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- ecstatic (npm): affected all versions; fixed in 4.1.3\n- ecstatic (npm): affected all versions; fixed in 4.1.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-10775/ (Markdown: https://insights.sbomify.com/CVE-2019-10775/index.md)","id":"CVE-2019-10775","markdown":"https://insights.sbomify.com/CVE-2019-10775/index.md","name":"CVE-2019-10775","record":{"aliases":["GHSA-jc84-3g44-wf2q"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"JavaScript library","requires_auth":"none","summary":"A denial of service vulnerability in the ecstatic library allows attackers to crash applications, requiring developers to upgrade the package.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"snyk","cpe":[{"product":"ecstatic","vendor":"ecstatic_project"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-400","name":"Uncontrolled Resource Consumption"}],"description":"ecstatic have a denial of service vulnerability. Successful exploitation could lead to crash of an application.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Denial of Service in ecstatic","id":"CVE-2019-10775","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2019"},"n_packages":2,"n_references":1,"next":{"headline":"OS command injection in git-diff-apply","id":"CVE-2019-10776"},"packages":[{"ecosystem":"npm","fixed":["4.1.3"],"introduced":["0"],"last_affected":[],"package":"ecstatic","purl":null,"source":"GHSA-jc84-3g44-wf2q"},{"ecosystem":"npm","fixed":["4.1.3"],"introduced":["0"],"last_affected":[],"package":"ecstatic","purl":"pkg:npm/ecstatic","source":"GHSA-jc84-3g44-wf2q"}],"prev":{"headline":"php-shellcommand command injection vulnerability","id":"CVE-2019-10774"},"products":["ecstatic"],"published":"2020-01-02","related":[{"cvss_score":7.5,"headline":"Denial of Service in ecstatic","id":"CVE-2015-9242","kev_date_added":null,"published":"2018-05-29"},{"cvss_score":7.5,"headline":"Denial of Service in ecstatic","id":"CVE-2016-10703","kev_date_added":null,"published":"2017-12-14"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"A denial of service vulnerability in the ecstatic library allows attackers to crash applications, requiring developers to upgrade the package.","url":"https://insights.sbomify.com/CVE-2019-10775/"}