# CVE-2019-10775: Denial of Service in ecstatic

> A denial of service vulnerability in the ecstatic library allows attackers to crash applications, requiring developers to upgrade the package.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Jan 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-jc84-3g44-wf2q

## What is CVE-2019-10775?

CVE-2019-10775 is a high-severity denial of service vulnerability in ecstatic, published on 2 Jan 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

ecstatic have a denial of service vulnerability. Successful exploitation could lead to crash of an application.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2019-10775?

2 open source packages ship an affected version, including ecstatic. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ecstatic` | npm | All versions | 4.1.3 |
| `ecstatic` | npm | All versions | 4.1.3 |

Products: Ecstatic Project Ecstatic.

## How do I fix CVE-2019-10775?

Upgrade ecstatic to 4.1.3 or later.

## Is CVE-2019-10775 being exploited?

There is no known exploitation of CVE-2019-10775 in the wild and no public exploit code.

## Other vulnerabilities in ecstatic

- [CVE-2015-9242](https://insights.sbomify.com/CVE-2015-9242/): Denial of Service in ecstatic (high 7.5)
- [CVE-2016-10703](https://insights.sbomify.com/CVE-2016-10703/): Denial of Service in ecstatic (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-10775 and fix it if it is affected.

What it is: CVE-2019-10775 is a high-severity denial of service vulnerability in ecstatic, published on 2 Jan 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-10775 in the wild and no public exploit code.

Affected packages and fixed versions:
- ecstatic (npm): affected all versions; fixed in 4.1.3
- ecstatic (npm): affected all versions; fixed in 4.1.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-10775/ (Markdown: https://insights.sbomify.com/CVE-2019-10775/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-10775
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-10775
- OSV: https://osv.dev/vulnerability/CVE-2019-10775

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-10775/
Summaries are generated and may contain mistakes; the official description above is the record.
