# CVE-2019-10777: OS command injection in aws-lambda

> Attackers can execute arbitrary commands via unsanitized function names in the aws-lambda Node.js library.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Jan 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-934x-72xh-5hrg

## What is CVE-2019-10777?

CVE-2019-10777 is a critical command injection vulnerability in aws-lambda, published on 8 Jan 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In aws-lambda versions prior to version 1.0.5, the "config.FunctioName" is used to construct the argument used within the "exec" function without any sanitization. It is possible for a user to inject arbitrary commands to the "zipCmd" used within "config.FunctionName".

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2019-10777?

2 open source packages ship an affected version, including aws-lambda. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `aws-lambda` | npm | All versions | 1.0.5 |
| `aws-lambda` | npm | All versions | 1.0.5 |

Products: Amazon Aws Lambda.

## How do I fix CVE-2019-10777?

Upgrade aws-lambda to 1.0.5 or later.

## Is CVE-2019-10777 being exploited?

There is no known exploitation of CVE-2019-10777 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-10777 and fix it if it is affected.

What it is: CVE-2019-10777 is a critical command injection vulnerability in aws-lambda, published on 8 Jan 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-10777 in the wild and no public exploit code.

Affected packages and fixed versions:
- aws-lambda (npm): affected all versions; fixed in 1.0.5
- aws-lambda (npm): affected all versions; fixed in 1.0.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-10777/ (Markdown: https://insights.sbomify.com/CVE-2019-10777/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-10777
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-10777
- OSV: https://osv.dev/vulnerability/CVE-2019-10777

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-10777/
Summaries are generated and may contain mistakes; the official description above is the record.
