{"answers":{"affected":"2 open source packages ship an affected version, including devcert-sanscache. It affects 1 product.","exploited":"There is no known exploitation of CVE-2019-10778 in the wild and no public exploit code.","fix":"Upgrade devcert-sanscache to 0.4.7 or later.","what":"CVE-2019-10778 is a critical command injection vulnerability in devcert-sanscache, published on 8 Jan 2020. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2019-10778 and fix it if it is affected.\n\nWhat it is: CVE-2019-10778 is a critical command injection vulnerability in devcert-sanscache, published on 8 Jan 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2019-10778 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- devcert-sanscache (npm): affected all versions; fixed in 0.4.7\n- devcert-sanscache (npm): affected all versions; fixed in 0.4.7\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-10778/ (Markdown: https://insights.sbomify.com/CVE-2019-10778/index.md)","id":"CVE-2019-10778","markdown":"https://insights.sbomify.com/CVE-2019-10778/index.md","name":"CVE-2019-10778","record":{"aliases":["GHSA-4gp3-p7ph-x2jr"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js certificate library","requires_auth":"none","summary":"Remote attackers can execute arbitrary code via command injection in the devcert-sanscache library due to unsanitized user input in the exec function.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"snyk","cpe":[{"product":"devcert-sanscache","vendor":"devcert-sanscache_project"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-78","name":"Improper Neutralization of Special Elements used in an OS Command"}],"description":"devcert-sanscache before 0.4.7 allows remote attackers to execute arbitrary code or cause a Command Injection via the exec function. The variable `commonName` controlled by user input is used as part of the `exec` function without any sanitization.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"OS Command Injection in devcert-sanscache","id":"CVE-2019-10778","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"command_injection","year":"2019"},"n_packages":2,"n_references":1,"next":{"headline":"Cross-site scripting in stroom:stroom-app","id":"CVE-2019-10779"},"packages":[{"ecosystem":"npm","fixed":["0.4.7"],"introduced":["0"],"last_affected":[],"package":"devcert-sanscache","purl":null,"source":"GHSA-4gp3-p7ph-x2jr"},{"ecosystem":"npm","fixed":["0.4.7"],"introduced":["0"],"last_affected":[],"package":"devcert-sanscache","purl":"pkg:npm/devcert-sanscache","source":"GHSA-4gp3-p7ph-x2jr"}],"prev":{"headline":"OS command injection in aws-lambda","id":"CVE-2019-10777"},"products":["devcert-sanscache"],"published":"2020-01-08","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"Remote attackers can execute arbitrary code via command injection in the devcert-sanscache library due to unsanitized user input in the exec function.","url":"https://insights.sbomify.com/CVE-2019-10778/"}