# CVE-2019-10778: OS Command Injection in devcert-sanscache

> Remote attackers can execute arbitrary code via command injection in the devcert-sanscache library due to unsanitized user input in the exec function.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Jan 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-4gp3-p7ph-x2jr

## What is CVE-2019-10778?

CVE-2019-10778 is a critical command injection vulnerability in devcert-sanscache, published on 8 Jan 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

devcert-sanscache before 0.4.7 allows remote attackers to execute arbitrary code or cause a Command Injection via the exec function. The variable `commonName` controlled by user input is used as part of the `exec` function without any sanitization.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2019-10778?

2 open source packages ship an affected version, including devcert-sanscache. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `devcert-sanscache` | npm | All versions | 0.4.7 |
| `devcert-sanscache` | npm | All versions | 0.4.7 |

Products: Devcert-Sanscache Project Devcert-Sanscache.

## How do I fix CVE-2019-10778?

Upgrade devcert-sanscache to 0.4.7 or later.

## Is CVE-2019-10778 being exploited?

There is no known exploitation of CVE-2019-10778 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-10778 and fix it if it is affected.

What it is: CVE-2019-10778 is a critical command injection vulnerability in devcert-sanscache, published on 8 Jan 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-10778 in the wild and no public exploit code.

Affected packages and fixed versions:
- devcert-sanscache (npm): affected all versions; fixed in 0.4.7
- devcert-sanscache (npm): affected all versions; fixed in 0.4.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-10778/ (Markdown: https://insights.sbomify.com/CVE-2019-10778/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-10778
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-10778
- OSV: https://osv.dev/vulnerability/CVE-2019-10778

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-10778/
Summaries are generated and may contain mistakes; the official description above is the record.
