{"answers":{"affected":"2 open source packages ship an affected version, including bibtex-ruby. It affects 1 product.","exploited":"There is no known exploitation of CVE-2019-10780 in the wild and no public exploit code.","fix":"Upgrade bibtex-ruby to 5.1.0 or later.","what":"CVE-2019-10780 is a critical vulnerability in BibTeX-ruby, published on 22 Jan 2020."},"fix_prompt":"Check this codebase for CVE-2019-10780 and fix it if it is affected.\n\nWhat it is: CVE-2019-10780 is a critical vulnerability in BibTeX-ruby, published on 22 Jan 2020. \nExploitation: There is no known exploitation of CVE-2019-10780 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- bibtex-ruby (RubyGems): affected all versions; fixed in 5.1.0\n- bibtex-ruby (RubyGems): affected all versions; fixed in 5.1.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-10780/ (Markdown: https://insights.sbomify.com/CVE-2019-10780/index.md)","id":"CVE-2019-10780","markdown":"https://insights.sbomify.com/CVE-2019-10780/index.md","name":"CVE-2019-10780","record":{"aliases":["GHSA-c5r5-7pfh-6qg6","SNYK-RUBY-BIBTEXRUBY-542602"],"analysis":null,"analysis_generated_by":null,"assigner":"snyk","cpe":[{"product":"bibtex-ruby","vendor":"bibtex-ruby_project"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-78","name":"Improper Neutralization of Special Elements used in an OS Command"}],"description":"BibTeX-ruby before 5.1.0 allows shell command injection due to unsanitized user input being passed directly to the built-in Ruby Kernel.open method through BibTeX.open.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"BibTeX-Ruby vulnerable to OS command injection","id":"CVE-2019-10780","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":null,"year":"2019"},"n_packages":2,"n_references":1,"next":{"headline":"Validation Bypass in schema-inspector","id":"CVE-2019-10781"},"packages":[{"ecosystem":"RubyGems","fixed":["5.1.0"],"introduced":["0"],"last_affected":[],"package":"bibtex-ruby","purl":null,"source":"GHSA-c5r5-7pfh-6qg6"},{"ecosystem":"RubyGems","fixed":["5.1.0"],"introduced":["0"],"last_affected":[],"package":"bibtex-ruby","purl":"pkg:gem/bibtex-ruby","source":"GHSA-c5r5-7pfh-6qg6"}],"prev":{"headline":"Cross-site scripting in stroom:stroom-app","id":"CVE-2019-10779"},"products":["BibTeX-ruby"],"published":"2020-01-22","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":null,"url":"https://insights.sbomify.com/CVE-2019-10780/"}