{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2019-10784 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2019-10784 is a critical vulnerability in phppgadmin, published on 4 Feb 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2019-10784 and fix it if it is affected.\n\nWhat it is: CVE-2019-10784 is a critical vulnerability in phppgadmin, published on 4 Feb 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2019-10784 in the wild and no public exploit code.\n\nAffected product: phppgadmin. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-10784/ (Markdown: https://insights.sbomify.com/CVE-2019-10784/index.md)","id":"CVE-2019-10784","markdown":"https://insights.sbomify.com/CVE-2019-10784/index.md","name":"CVE-2019-10784","record":{"aliases":["DEBIAN-CVE-2019-10784","GHSA-84mp-rmf8-wc24","MGASA-2021-0074","SNYK-PHP-PHPPGADMINPHPPGADMIN-543885","UBUNTU-CVE-2019-10784","openSUSE-SU-2022:10065-1","openSUSE-SU-2024:12194-1"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"PostgreSQL admin tool","requires_auth":"none","summary":"A CSRF vulnerability in phpPgAdmin allows attackers to trick administrators into executing arbitrary system commands on the server.","user_interaction":"required","vuln_class":"csrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"snyk","cpe":[{"product":"phppgadmin","vendor":"phppgadmin_project"}],"cvss":{"score":9.6,"severity":"critical","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-352","name":"Cross-Site Request Forgery"}],"description":"phppgadmin through 7.12.1 allows sensitive actions to be performed without validating that the request originated from the application. One such area, \"database.php\" does not verify the source of an HTTP request. This can be leveraged by a remote attacker to trick a logged-in administrator to visit a malicious page with a CSRF exploit and execute arbitrary system commands on the server.","ecosystems":["SUSE:Package Hub 15 SP3","SUSE:Package Hub 15 SP4","openSUSE:Leap 15.3","openSUSE:Leap 15.4"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cross-site request forgery in phppgadmin","id":"CVE-2019-10784","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"csrf","year":"2019"},"n_packages":4,"n_references":1,"next":{"headline":"XSS in dojox due to insufficient escape in dojox.xmpp.util.xmlEncode","id":"CVE-2019-10785"},"packages":[{"ecosystem":"SUSE:Package Hub 15 SP3","fixed":["7.13.0-bp154.2.3.1"],"introduced":["0"],"last_affected":[],"package":"phpPgAdmin","purl":"pkg:rpm/suse/phpPgAdmin\u0026distro=SUSE%20Package%20Hub%2015%20SP3","source":"openSUSE-SU-2022:10065-1"},{"ecosystem":"SUSE:Package Hub 15 SP4","fixed":["7.13.0-bp154.2.3.1"],"introduced":["0"],"last_affected":[],"package":"phpPgAdmin","purl":"pkg:rpm/suse/phpPgAdmin\u0026distro=SUSE%20Package%20Hub%2015%20SP4","source":"openSUSE-SU-2022:10065-1"},{"ecosystem":"openSUSE:Leap 15.3","fixed":["7.13.0-bp154.2.3.1"],"introduced":["0"],"last_affected":[],"package":"phpPgAdmin","purl":"pkg:rpm/opensuse/phpPgAdmin\u0026distro=openSUSE%20Leap%2015.3","source":"openSUSE-SU-2022:10065-1"},{"ecosystem":"openSUSE:Leap 15.4","fixed":["7.13.0-bp154.2.3.1"],"introduced":["0"],"last_affected":[],"package":"phpPgAdmin","purl":"pkg:rpm/opensuse/phpPgAdmin\u0026distro=openSUSE%20Leap%2015.4","source":"openSUSE-SU-2022:10065-1"}],"prev":{"headline":"OS Command Injection in lsof","id":"CVE-2019-10783"},"products":["phppgadmin"],"published":"2020-02-04","related":[{"cvss_score":9.8,"headline":"Deserialization in n/a","id":"CVE-2023-40619","kev_date_added":null,"published":"2023-09-20"},{"cvss_score":6.5,"headline":"phppgadmin contains a SQL injection vulnerability","id":"CVE-2025-60797","kev_date_added":null,"published":"2025-11-20"},{"cvss_score":6.5,"headline":"phppgadmin contains a SQL injection vulnerability","id":"CVE-2025-60798","kev_date_added":null,"published":"2025-11-20"},{"cvss_score":6.1,"headline":"phppgadmin vulnerable to Cross-site Scripting","id":"CVE-2025-60796","kev_date_added":null,"published":"2025-11-20"},{"cvss_score":6.1,"headline":"phppgadmin contains an incorrect access control vulnerability","id":"CVE-2025-60799","kev_date_added":null,"published":"2025-11-20"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"A CSRF vulnerability in phpPgAdmin allows attackers to trick administrators into executing arbitrary system commands on the server.","url":"https://insights.sbomify.com/CVE-2019-10784/"}