# CVE-2019-10785: XSS in dojox due to insufficient escape in dojox.xmpp.util.xmlEncode

> Attackers can execute arbitrary scripts via Cross-site Scripting due to incomplete character encoding in the dojox.xmpp.util.xmlEncode function.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 13 Feb 2020
- **Updated:** 4 Aug 2024
- **Also known as:** DEBIAN-CVE-2019-10785, DLA-2127-1, GHSA-pg97-ww7h-5mjr, MGASA-2020-0126, SNYK-JS-DOJOX-548257,, UBUNTU-CVE-2019-10785

## What is CVE-2019-10785?

CVE-2019-10785 is a medium-severity cross-site scripting vulnerability in Debian Debian Linux, published on 13 Feb 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

dojox is vulnerable to Cross-site Scripting in all versions before version 1.16.1, 1.15.2, 1.14.5, 1.13.6, 1.12.7 and 1.11.9. This is due to dojox.xmpp.util.xmlEncode only encoding the first occurrence of each character, not all of them.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2019-10785?

12 open source packages ship an affected version, including dojox. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `dojox` | npm | All versions | 1.11.9 |
| `dojox` | npm | All versions | 1.11.9 |
| `dojox` | npm | From 1.12.0 | 1.12.7 |
| `dojox` | npm | From 1.12.0 | 1.12.7 |
| `dojox` | npm | From 1.13.0 | 1.13.6 |
| `dojox` | npm | From 1.13.0 | 1.13.6 |
| `dojox` | npm | From 1.14.0 | 1.14.5 |
| `dojox` | npm | From 1.14.0 | 1.14.5 |
| `dojox` | npm | From 1.15.0 | 1.15.2 |
| `dojox` | npm | From 1.15.0 | 1.15.2 |
| `dojox` | npm | From 1.16.0 | 1.16.1 |
| `dojox` | npm | From 1.16.0 | 1.16.1 |

Products: Debian Debian Linux, Linuxfoundation Dojox.

## How do I fix CVE-2019-10785?

Upgrade dojox to a fixed version for your release line: 1.11.9, 1.12.7, 1.13.6 or 1.14.5.

## Is CVE-2019-10785 being exploited?

There is no known exploitation of CVE-2019-10785 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-10785 and fix it if it is affected.

What it is: CVE-2019-10785 is a medium-severity cross-site scripting vulnerability in Debian Debian Linux, published on 13 Feb 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2019-10785 in the wild and no public exploit code.

Affected packages and fixed versions:
- dojox (npm): affected all versions; fixed in 1.11.9
- dojox (npm): affected all versions; fixed in 1.11.9
- dojox (npm): affected from 1.12.0; fixed in 1.12.7
- dojox (npm): affected from 1.12.0; fixed in 1.12.7
- dojox (npm): affected from 1.13.0; fixed in 1.13.6
- dojox (npm): affected from 1.13.0; fixed in 1.13.6
- dojox (npm): affected from 1.14.0; fixed in 1.14.5
- dojox (npm): affected from 1.14.0; fixed in 1.14.5
- dojox (npm): affected from 1.15.0; fixed in 1.15.2
- dojox (npm): affected from 1.15.0; fixed in 1.15.2
- dojox (npm): affected from 1.16.0; fixed in 1.16.1
- dojox (npm): affected from 1.16.0; fixed in 1.16.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-10785/ (Markdown: https://insights.sbomify.com/CVE-2019-10785/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-10785
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-10785
- OSV: https://osv.dev/vulnerability/CVE-2019-10785

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-10785/
Summaries are generated and may contain mistakes; the official description above is the record.
