# CVE-2019-10795: Prototype Pollution in undefsafe

> Attackers can pollute Object.prototype via the undefsafe library, potentially leading to code execution or privilege escalation in Node.js applications.

- **Severity:** Medium 6.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Feb 2020
- **Updated:** 4 Aug 2024
- **Also known as:** AZL-44064, GHSA-332q-7ff2-57h2, SNYK-JS-UNDEFSAFE-548940

## What is CVE-2019-10795?

CVE-2019-10795 is a medium-severity vulnerability in Snyk undefsafe, published on 18 Feb 2020. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

undefsafe before 2.0.3 is vulnerable to Prototype Pollution. The 'a' function could be tricked into adding or modifying properties of Object.prototype using a __proto__ payload.

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component)

## Which versions are affected by CVE-2019-10795?

2 open source packages ship an affected version, including undefsafe. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `undefsafe` | npm | All versions | 2.0.3 |
| `undefsafe` | npm | All versions | 2.0.3 |

Products: Undefsafe Project Undefsafe.

## How do I fix CVE-2019-10795?

Upgrade undefsafe to 2.0.3 or later.

## Is CVE-2019-10795 being exploited?

There is no known exploitation of CVE-2019-10795 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-10795 and fix it if it is affected.

What it is: CVE-2019-10795 is a medium-severity vulnerability in Snyk undefsafe, published on 18 Feb 2020. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-10795 in the wild and no public exploit code.

Affected packages and fixed versions:
- undefsafe (npm): affected all versions; fixed in 2.0.3
- undefsafe (npm): affected all versions; fixed in 2.0.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-10795/ (Markdown: https://insights.sbomify.com/CVE-2019-10795/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-10795
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-10795
- OSV: https://osv.dev/vulnerability/CVE-2019-10795

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-10795/
Summaries are generated and may contain mistakes; the official description above is the record.
