CVE-2019-10800 Command Injection
Medium 6.5
Published
Updated
Check this codebase for CVE-2019-10800 and fix it if it is affected.
What it is: CVE-2019-10800 is a medium-severity vulnerability in codecov, published on 13 Jul 2022.
Exploitation: There is no known exploitation of CVE-2019-10800 in the wild and no public exploit code.
Affected packages and fixed versions:
- codecov (PyPI): affected all versions; fixed in 2.0.16
- codecov (PyPI): affected all versions; fixed in 2.0.16
- codecov (PyPI): affected all versions; fixed in 2.0.16
Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.
Reference: https://insights.sbomify.com/CVE-2019-10800/ (Markdown: https://insights.sbomify.com/CVE-2019-10800/index.md)
- Exploited in the wild
- Not known
- Fix
- Available
What is CVE-2019-10800?
CVE-2019-10800 is a medium-severity vulnerability in codecov, published on 13 Jul 2022.
Official description
This affects the package codecov before 2.0.16. The vulnerability occurs due to not sanitizing gcov arguments before being being provided to the popen method.
Weakness: CWE-88
Which versions are affected by CVE-2019-10800?
3 open source packages ship an affected version, including codecov. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
codecov PyPI | All versions | 2.0.16 |
codecov PyPI | All versions | 2.0.16 |
codecov PyPI | All versions | 2.0.16 |
Linux distribution packages (2)
python-codecov openSUSE:Leap 15.3 | All versions | 2.0.15-150100.3.3.1 |
python-codecov openSUSE:Leap 15.4 | All versions | 2.0.15-150100.3.3.1 |
Products include Codecov Codecov-Python.
How do I fix CVE-2019-10800?
Upgrade codecov to 2.0.16 or later.
Is CVE-2019-10800 being exploited?
There is no known exploitation of CVE-2019-10800 in the wild and no public exploit code.
Sources
Also known as GHSA-h3qr-fjhm-jphw, PYSEC-2022-238, SNYK-PYTHON-CODECOV-552149, SUSE-SU-2022:2752-1.