# CVE-2019-10800: Command Injection


- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N/E:P/RL:O/RC:C`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 13 Jul 2022
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-h3qr-fjhm-jphw, PYSEC-2022-238, SNYK-PYTHON-CODECOV-552149, SUSE-SU-2022:2752-1

## What is CVE-2019-10800?

CVE-2019-10800 is a medium-severity vulnerability in codecov, published on 13 Jul 2022. 

### Official description

This affects the package codecov before 2.0.16. The vulnerability occurs due to not sanitizing gcov arguments before being being provided to the popen method.

Weakness: CWE-88 (Improper Neutralization of Argument Delimiters in a Command)

## Which versions are affected by CVE-2019-10800?

3 open source packages ship an affected version, including codecov. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `codecov` | PyPI | All versions | 2.0.16 |
| `codecov` | PyPI | All versions | 2.0.16 |
| `codecov` | PyPI | All versions | 2.0.16 |
| `python-codecov` | openSUSE:Leap 15.3 | All versions | 2.0.15-150100.3.3.1 |
| `python-codecov` | openSUSE:Leap 15.4 | All versions | 2.0.15-150100.3.3.1 |

Products: Codecov Codecov-Python.

## How do I fix CVE-2019-10800?

Upgrade codecov to 2.0.16 or later.

## Is CVE-2019-10800 being exploited?

There is no known exploitation of CVE-2019-10800 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-10800 and fix it if it is affected.

What it is: CVE-2019-10800 is a medium-severity vulnerability in codecov, published on 13 Jul 2022. 
Exploitation: There is no known exploitation of CVE-2019-10800 in the wild and no public exploit code.

Affected packages and fixed versions:
- codecov (PyPI): affected all versions; fixed in 2.0.16
- codecov (PyPI): affected all versions; fixed in 2.0.16
- codecov (PyPI): affected all versions; fixed in 2.0.16

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-10800/ (Markdown: https://insights.sbomify.com/CVE-2019-10800/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-10800
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-10800
- OSV: https://osv.dev/vulnerability/CVE-2019-10800

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-10800/
Summaries are generated and may contain mistakes; the official description above is the record.
