# CVE-2019-10808: Improperly Controlled Modification of Dynamically-Determined Object Attributes in utilitify

> Attackers can modify Object.prototype properties via the merge method, potentially leading to code execution or privilege escalation in applications using the library.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Mar 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-9534-h433-2rjf

## What is CVE-2019-10808?

CVE-2019-10808 is a high-severity code injection vulnerability in utilitify, published on 11 Mar 2020. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

utilitify prior to 1.0.3 allows modification of object properties. The merge method could be tricked into adding or modifying properties of the Object.prototype.

Weakness: CWE-1321 (Improperly Controlled Modification of Object Prototype Attributes)

## Which versions are affected by CVE-2019-10808?

2 open source packages ship an affected version, including utilitify. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `utilitify` | npm | All versions | 1.0.3 |
| `utilitify` | npm | All versions | 1.0.3 |

Products: Xcritical.software Utilitify.

## How do I fix CVE-2019-10808?

Upgrade utilitify to 1.0.3 or later.

## Is CVE-2019-10808 being exploited?

There is no known exploitation of CVE-2019-10808 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-10808 and fix it if it is affected.

What it is: CVE-2019-10808 is a high-severity code injection vulnerability in utilitify, published on 11 Mar 2020. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-10808 in the wild and no public exploit code.

Affected packages and fixed versions:
- utilitify (npm): affected all versions; fixed in 1.0.3
- utilitify (npm): affected all versions; fixed in 1.0.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-10808/ (Markdown: https://insights.sbomify.com/CVE-2019-10808/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-10808
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-10808
- OSV: https://osv.dev/vulnerability/CVE-2019-10808

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-10808/
Summaries are generated and may contain mistakes; the official description above is the record.
